Rocky-XFCE-8 doesn't boot on old laptop

the Rocky-XFCE-8-x86_64-20220515.4.iso boots not on an old Fujitsu Lifebook E8310 Notebook. When i run the media check it fails ever on 090.5%, ubuntu boots fine. i have copied it multiple times with dd, ever the same error.

Verify the checksum on the image that you downloaded.

the checksum was correct, dd if=./Rocky-XFCE-8-x86_64-20220515.4.iso of=/dev/sdb bs=4096 conv=sync should be work?

okay now it works, but the sync command ends never when i run it, maybe a bug of my usb stick? its a Kingston DTSE9 32GB

okay now i have it re-copied and waited a bit longer and now everything seems 100% ok, check completes successfull

but the wireless of the lifebook e8310 doesn’t work, what driver is required for Qualcomm Atheros AR242x / AR542x Wireless Network (rev 04)? [168c:001c] device id and the ethernet lan device is also not detected, its a Marvell Technology Group Ltd. 88E8055 PCI-E Gigabit Ethernet Controller (rev 14) [11ab:4363]

Presumably 168c:001c. The modprobe -c | grep 168C does list only ath9k and ath10k_pci, which do not support the 001C.

ELRepo has ath5k listed for it in ELRepo | DeviceIDs

dnf install elrepo-release
dnf install kmod-ath5k

but AX88179 usb ethernet adapter is detected instant and works when i plug it in

For that ELRepo has package kmod-sky2.

Good. What is its device ID?

it have [0b95:1790] as device ID

For that EL8 has driver ax88179_178a:

$ modprobe -c | grep -i 0b95.*1790
alias usb:v0B95p1790d*dc*dsc*dp*ic*isc*ip*in* ax88179_178a

but for any usb ethernet adapter it works immediately, but sata drives are also not recognized. the laptop has a Intel 82801HM/HEM (ICH8M/ICH8M-E) SATA controller

Perhaps USB ethernet adapters are “standard” or EL8 has wide selection of drivers for them. That is why the work “out of the box”.

What is the device ID of the SATA controller?

Storage is more fun during than network; one can install from local media without net, but one can’t install from net, if one can’t write to storage. Not impossible though, ELRepo has “dud” (driver update disk) images that installer can use as additional sources, so installer can be augmented with drivers. If ELRepo has dud for your controller.

00:1f.2 is the device ID of controller, and “Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode]” is the name of controller

No, the 00:1f.2 is the location of the device (format of that is [[[[<domain>]:]<bus>]:][<device>][.[<func>]]).
The device ID is something like [ 8086:a352] as in:

$ lspci -nn -s 00:17.0
00:17.0 SATA controller [0106]: Intel Corporation Cannon Lake PCH SATA AHCI Controller [8086:a352] (rev 10)

(So on my machine function 0 of device 17 on bus 00 is AHCI Controller with ID [8086:a352].)
You probably have [8086:2829], but if it does … 8.6’s kernel says:

$ modprobe -c | grep -i 8086.*2829
alias pci:v00008086d00002829sv*sd*bc*sc*i* ahci

So included driver ‘ahci’ should regognize that controller?

8086:2829 is the device id of the SATA Controller and 11ab:4363 is the ID of the onboard Marvell Ethernet Controller(as I had already written)

and yes, mine looks exactly like your post

its one to one the same

but the hdds are completely misidentified

neither the USB stick nor the installed hard disk is recognized correctly

How about lspci -v -s 00:1f.2
That might show “Kernel modules” and “Kernel driver in use” fields.

both is shown ‘ahci’

fdisk detects all good, but in anaconda installer it is not detected

If driver for SATA controller exists and is loaded, but do disks are visible, then where is the issue?

Do lsblk and blkid reveal anything?

in anaconda there is no hard disk detected

yes lsblk and blkid detects all correct

it must be a bug in anaconda

‘no storage media found’ is displayed in anaconda