Rocky 9.3 network install: network not started

Hi all,

trying to install 9.3 via Infiniband, using an ipxe file (+ kickstart), fails.
iPXE lines:

set repo ...
set kickstart ...
set route ...
set dns ...
set netmask ...
 set ip_config inst.ip=${net0.dhcp/ip}::${gateway}:${netmask}:${net0.dhcp/hostname}.gsi.de:ibp49s0:none inst.nameserver=${dns} inst.rd.route=${route} inst.ipv6.disable=1  inst.bootdev=ibp49s0

As you can see, in an act of self-humiliation, I even put in the unpredictable network interface name that shows up during the failed attempts. The previous attempt with ib0 failed just as badly.

journalctl in the dracut shell reveals that all my parameters have arrived

Kernel command line: initrd=initrd.img inst.ip=10.20.4.98::10.20.0.1:255.255.0.0:lxbk0704.gsi.de:ibp49s0:none inst.nameserver=10.10.24.192 inst.rd.route=10.20.0.0/16:10.20.0.1:ibp49s0 inst.ipv6.disable=1 inst.rd.bootdev=ibp49s0 inst.repo=http://...

Further on in the boot process, I see

NetworkManager: ... device (ibo49s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
...
NetworkManager: ... manager: startup complete
systemd: Finished nm-wait-online-initrd.service.

After this, dracut-initqueue: anaconda starts complaining it cannot load stage2 etc. - obviously no network.

In the dracut shell, I see the IB network interface “UP”, but without an IP address.
(I’m not sure if it is meant to be managed by NetworkManager, these messages could also be misleading - systemctl cannot find the Unit NetworkManager.service at that stage.)

My impression is that it is not a matter of timeout - the anaconda-loading-and-failing attempts run for several minutes. Looks rather like there is no more attempt in the background to actuall start a network.

Btw, this entire procedure has been used successfully for Rocky 8.x installations.

Regards,
Thomas

“ibo” there is a typo, right?

I suppose it must not be a card whose support was dropped between 8 and 9 (e.g. pre-3 ConnectX) or you wouldn’t be seeing an IPoIB interface at all.

The boot options for RHEL-9 are in Boot options for RHEL Installer Red Hat Enterprise Linux 9 | Red Hat Customer Portal
No “inst.ip=” among them …

1 Like

Do you have secure boot set? We had to disable secure boot, kick our server and then reenable secure boot.