Rocky 9.3 instalation problem with gpt

I am trying to install rocky 9.3. in a supermicro. I would like to do it with MBR but I am not be able and always Rocky is installed with gpt. When I finish the instalation and I do fidisk -l I get the follow error

The backup GPT table is corrupt, but the primary appears OK, so that will be used.
GPT PMBR size mismatch (445413375 != 468862127) will be corrected by write.
The backup GPT table is not on the end of the device.

I have tried
fdisk /dev/sda

Welcome to fdisk (util-linux 2.37.4).
Changes will remain in memory only, until you decide to write them.
Be careful before using the write command.

The backup GPT table is corrupt, but the primary appears OK, so that will be used.
This disk is currently in use - repartitioning is probably a bad idea.
It’s recommended to umount all file systems, and swapoff all swap
partitions on this disk.

The device contains ‘isw_raid_member’ signature and it will be removed by a write command. See fdisk(8) man page and --wipe option for more details.

Command (m for help): w

But it does not resolve anything

I have tried

sgdisk -e /dev/sda
Caution: invalid backup GPT header, but valid main header; regenerating
backup header from main header.

Warning! Main and backup partition tables differ! Use the ‘c’ and ‘e’ options
on the recovery & transformation menu to examine the two tables.

Warning! One or more CRCs don’t match. You should repair the disk!
Main header: OK
Backup header: ERROR
Main partition table: OK
Backup partition table: ERROR

Caution: Found protective or hybrid MBR and corrupt GPT. Using GPT, but disk
verification and recovery are STRONGLY recommended.

Warning: The kernel is still using the old partition table.
The new table will be used at the next reboot or after you
run partprobe(8) or kpartx(8)
The operation has completed successfully.

But when I reboot the system doesn’t boot.

I don’t know what options in BIOS I would have to use for a mbr instalation, because when I try it with no efi usb then the system not recognize the disk where the SO is going to be instaled

Can anyone help me? thanks in advance

Legacy boot mode uses MBR. UEFI boot mode requires GPT, because UEFI seeks bootloaders from ESP.

I would start the installer in troubleshoot mode, or switch to console on normal install mode, or boot some “live” media and then wipe the disk(s) clean (with dd, etc). Then (re)boot to installer.

Isn’t “isw_raid” a fakeRAID? There should be no need for that.

gdisk has been the primary tool for GPT. Support for GPT in fdisk has increased though. I can’t even remember the decade I’ve last seen sgdisk.

Then I suggest you consult the documentation for your particular SuperMicro motherboard/server; they provide great docs for their products, and this should be an easy thing to find. Usually this sort of thing would be under Boot Options or something similar in the system BIOS, and you would want to specify something like BIOS or MBR instead of UEFI.

Attempting to use MBR on a UEFI system often fails to work, so it failing to boot isn’t surprising.

Out of curiosity, is there any particular reason you specifically wish to use MBR instead of UEFI?

This indicates your system is configured to use the Intel Rapid Storage “RAID” controller, and likely already contains some form of prior OS installation (or at least has existing partitions of some sort). I think dmraid supports that controller in linux, but mdadm definitely won’t recognize it.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.