Rocky 9.1 Foreman Sync Error - Possible issue with repository metadata

Hi guys,

First time posting, sorry if this is posted in the wrong place.

I am syncing Rocky 9.1 repositories with Foreman 3.5.1 and it is tripping up over 1 particular package from the repositories at path /rocky/9/AppStream/x86_64/os/Packages/h/

hyperv-tools-0-0.40.20190303git.el9_1.1.noarch.rpm 25-Jan-2023 16:22               14157

It is giving the following error about an issue with the expected size:
A file located at the url failed validation due to size. Expected ‘14233’, Actual ‘14157’

This appears to be the relevant metadata from this file:

<package type="rpm"><name>hyperv-tools</name><arch>noarch</arch><version epoch="0" ver="0" rel="0.40.20190303git.el9_1.1"></version><checksum type="sha256" pkgid="YES">0140116450ab5a94be5e1d93e8a9fd4694bc666bf0a2ac5c3c1f43eac4fd85c9</checksum><summary>Tools for Hyper-V guests</summary><description>Contains tools and scripts useful for Hyper-V guests.</description><packager>Rocky Linux Build System (Peridot) &lt;;</packager><url></url><time file="1674502311" build="1674502310"></time><size package="14233" installed="20008" archive="20400"></size><location href="Packages/h/hyperv-tools-0-0.40.20190303git.el9_1.1.noarch.rpm"></location><format><rpm:license>GPLv2</rpm:license><rpm:vendor>Rocky Enterprise Software Foundation</rpm:vendor><rpm:group>Unspecified</rpm:group><rpm:buildhost>pb-4d19d2c0-0c8c-4212-aeb3-41d38d8ffefe-b-i686</rpm:buildhost><rpm:sourcerpm>hyperv-daemons-0-0.40.20190303git.el9_1.1.src.rpm</rpm:sourcerpm><rpm:header-range start="4504" end="8773"></rpm:header-range><rpm:provides><rpm:entry name="hyperv-tools" flags="EQ" epoch="0" ver="0" rel="0.40.20190303git.el9_1.1"></rpm:entry></rpm:provides><rpm:requires><rpm:entry name="/usr/bin/python3"></rpm:entry></rpm:requires><file>/usr/sbin/lsvmbus</file><file>/usr/sbin/vmbus_testing</file></format></package>

The issue is perhaps here:
<size package="14233" installed="20008" archive="20400"></size>

Does anyone know how this can be resolved?


Hi @joshwhiteside,

Thank you for bringing this up!

There was something similar happening a few days ago, so I thought it might be the same thing again,
but I unfortunately can’t reproduce it in my location, maybe my CDN endpoint is not as new as the one where you are, so will try later again. (also tried against a local mirror, which also does not seem to have this issue)
Could you please also try once again?

Hi @lumarel

Thanks for checking this from your location.

I am syncing directly from Index of /pub/rocky/9/AppStream/ so I imagine it is the most up to date. I did try syncing it again but unfortunately no luck.

I wonder if this issue causes the mirrors to fail to sync as well.


Oh the thing is, is a CDN hosted by Fastly, so in the best case we should have the same state, but caching is still a thing per CDN endpoint, so yeah very interesting…

Could you do a verbose curl against one of the files and look what the x-powered-by is? (I think that was the property which serves the name of the current CDN endpoint)

Hi @lumarel

Oh interesting, I did not realise that. Thanks for the info

The closest thing I could find is the x-served-by

x-served-by: cache-chi-klot8100103-CHI, cache-lcy-eglc8600021-LCY

Seems like the relevant header:

Okay thank you, I’ve retried over and over again now, still not happening on my endpoint, so I have forwarded it to releng/infra now, maybe a cache clear does already the trick or maybe it’s more and they will find the bug, thank you once again!

Thanks for all your help @lumarel , have a good weekend

1 Like