Removed Nvidia Drivers Now I Can't Boot or Login

Welllll, I have been trying to reboot my machine after I tried to unsuccessfully install the Nvivia Drivers MANUALLY since the cut-‘n’-paste EASY method did not work. I removed the blacklist nouveau references etc., and got it back to the state where the boot should have worked, but it doesn’t. I what get is the spinning worm (not the Nvidia 3 orange dots ), which stops and then it stops, gives me a BLACK SCREEN, then there is a string of OK’s that flash by, and then hangs instead of giving me the login screen.

Next I got more SERIOUS and tried to RESCUE the system, which FAILED. I tried to edit the kernel by appending to the line that says Linux. Got to the point where I entered my root password, but then got lost trying to troubleshoot the problem – the problem is I can’t get it to boot! I tried startx but that does not work.

Before I get SUPER SERIOUS and simply try to replace /boot from a install thumb drive – which may REALLY toast the system – Before I get to that point I thought I’d check into here to see if any of you have any suggestions (besides putting a bullet through its CPU and end its misery ).

I really would like to avoid doing a total reinstall of the system, and I wonder if just installing a NEW /boot would kick start the bloody thing.

As an aside does anyone know when there will be a NEW kernel update over yada,yada, 9.1-yada, yada? I am sitting pat at 8.5 before I attempt a new rollover on my main machine (ocelot) which right now is running openSUSE 15.3 Leap ( which can be upgraded to 15.4 by standing on ones head, saying special incantations, while sacrificing ones first born. ).

D’ Cat

As a suggestion, I get similar problems with nvidia drivers on CentOS 7. The system is actually booting and on the network - the problem is that xwindows isn’t starting so you don’t get the typical GUI login screen. Is it on a network? Can you try to ssh to that machine from another one? Also, try doing a CTRL-ALT-F2 and see if you get a commandline login prompt.
Installing the nvidia drivers is actually a little complicated. I would need to go through some notes to remember all the steps it took to get it working correctly.

Have you considered using an AMD graphics processing unit, as opposed to NVidia?

Well… Did try CTL-ALT-F2 – No go there too. Tried a half dozen things, none of which worked. Two days ago I burned a copy of RL 8.6 to a thumb drive and on Wed. I took the EXTREME step of of doing a partial reinstall – ie I replaced the /boot, and – forced too – / partitions. The Good News / Bad News: The Good News is that I now have jaguar booting; the Bad News is that I am going to have to re-create all the VD, configuration files etc. I’m not sure if by doing so I also wrecked other files etc. I’ll need to survey the wreckage in the coming days. I am hoping things such as /home and other directories were not touched, but end up having to re-install mc (Midnight Commander), KDE, etc., I have also been forced with having to deal with the lockup of the screen by the screen saver. Since I no longer have access to the previous kernel, since I ONLY have the 9.1 kernel of 8.6, I can’t drop back to the previous kernel workaround. I have – I hope figured out a different work around: I simply disabled the screen locker. Hopefully this problem will be taken care of in the next kernel release… whenever that is. I have the Nvidia drivers working in CentOS 7, and have since the Jurassic, but it seems that the CentOS 7 procedure has changed fairly recently (that was one of the ways I tried that FAILED). When I installed the driver in CentOS 7, the only thing that needed to be updated was the kmod-nividia driver, when that failed it meant that a new point release was on the way, so updates usually included the --exclude=kmod-nvidia xyz, then when the point release came out and I rolled over the machine the kernel and the kmod drivers were in sync again. But that was usually the ONLY thing I had to do. NOW?!? Go figure. One thing that FAILED was the MANUAL install, a simple removing – ie reversing – of the changes you made, did NOT bring me back to the nouveau default. Given that jaguar aka the “Kitty Litter Box”, was NOT backed up meant I was unable to roll back the changes like can do on leopard, which is what saved my bacon when i rolled over my workstation to 8.6 which then blew up big time – I lost maybe 4-5 hours rolling it back to 8.5 not over a week or more more in the case of jaguar. There are no redundancy drives in jaguar, which is maxed out at 500 GiB total – yes jaguar is that old, which makes it perfect for testing things on, whereas both leopard and ocelot have multiple drives as well as a 2TB backup drive, and even backup partitions where things can be temporarily moved to, jaguar simply has a total max capacity of 500 GiB, is taken up in a single 500 GiB HDD (it can’t even use SATA drives).

In its next life jaguar will be used for testing RL 9.1 (9.0 is DOA I refuse to touch any XYZ.0 distro). I might buy a second 500 GiB HDD so I can work with both RL 8.x and 9.x by simply changing the ribbon and power cables from one drive to the other.

Would, but this is really, REALLY OLD – I think it dates back to 2010 – jaguar has an ancient Nvidia GeForce GT 7500LE card in it.

The other thing is it has to have a VGA port native since my 4 position KVMA switch is VGA – adapters tend to do some strange things in output as I have found out with ocelot – it currently has a Nvidia GeForce GT 730 in it. I have a Nvidia GeForce GTX 1050 Ti that has VGA that I need to stick back into ocelot to see if it will work. As I recall it raised a hissy fit the last time I tried it, and fell across the GT 730 laying around.

My knowledge of Radeon Graphics Cards is non-existent and I have no idea what Radeon card matches its equivalent Nvidia card, and if it has a VGA port natively. But Yeah, I’ve considered it.