Mount LUKS partitions

Hi all.

During the installation I’ve choose to secure my 2 TB HDD, where I put ‘not that useful things’, my main disk of the / and the disk of the /home with passwords, and it’s working fine, BUT, I need to make a little change on it.

My entire 2TB HDD was set to /home/Downloads during the installation, but now I fell the need to ‘split it’ into two folders and mount the same LUKS 2TB HDD into 2 different folder locations.

Here is what it looks now (working fine):

/dev/mapper/luks-2TB_HDD          /home/my_user/Downloads  XFS defaults and more

But I need something like:

/dev/mapper/luks-2TB_HDD/Downloads                /home/my_user/Downloads
/dev/mapper/luks-2TB_HDD/VM                            /home/my_user/VM

I’ve alraed tried to write /Download and /VM after the numbers of LUKS mounting, but It doesn’t work, so here I am.

Any pro tips?

To get a clearer picture, can you try this command


And here we go:

sda                8:0               447,1G           disk  
└─sda1             8:1   crypto_LUKS 447,1G           part  
sdb                8:16                1,8T           disk  
└─sdb1             8:17  crypto_LUKS   1,8T           part  
                 253:2   xfs           1,8T SECTION_9 crypt /home/gits/VM
sdc                8:32                3,6T           disk  
└─sdc1             8:33  crypto_LUKS   3,6T           part  
                 253:3   xfs           3,6T TOKYO     crypt /home/gits/Downloads
sdd                8:48                3,6T           disk  
└─sdd1             8:49  crypto_LUKS   3,6T           part  
nvme1n1          259:0               465,8G           disk  
└─nvme1n1p1      259:1   crypto_LUKS 465,8G           part  
                 253:4   xfs         465,7G PERSONAL  crypt /home
nvme0n1          259:2               232,9G           disk  
├─nvme0n1p1      259:3   xfs             1G BOOM      part  /boot
├─nvme0n1p2      259:4   vfat            1G EFI       part  /boot/efi
├─nvme0n1p3      259:5   crypto_LUKS   150G           part  
│ └─luks-0c8a50f8-d85a-4869-8286-de9ce932a565
│                253:1   xfs           150G SYSTER    crypt /
└─nvme0n1p4      259:6   crypto_LUKS  80,9G           part  
                 253:0   swap         80,9G SWAP      crypt [SWAP]

Since the post I moved the 2TB partition to the gits/VM and attached a new LUKS 4TB HDD into he Downloads folder.

The 4TB HDD is a secondary bakup that I have, so it’s not good to use this way in my case.

The diagram is very clear, but the goalpost has moved since your original post, so I’m not sure what you’re trying to do. Which exact line in the diagram is the one you are trying to work on?

I’m trying something like

/dev/mapper/luks-df4c4fa5-61ad-4a01-a9e9-5719748515cf/HDD			/home/gits/HDD 			xfs 		defaults,x-gvfs-hide 0 0
/dev/mapper/luks-df4c4fa5-61ad-4a01-a9e9-5719748515cf/DOWNLOADS			/home/gits/Downloads		xfs 		defaults,x-gvfs-hide 0 0

In other words, mount one partition twice with different folders mounted in different places.

In the example above I should have a HDD and a Downloads folders inside of the LUKS disk and them mount each folder inside different places of my home folder.

Usually should be something like (if I remember correctly from my Arch installs):

/dev/sda1/HDD                               /home/gits/HDD
/dev/sda1/DOWNLOADS               /home/gits/Downloads

But I don’t know how to point the LUKS partition in this case.

I’ve tried

/dev/mapper/luks-df4c4fa5-61ad-4a01-a9e9-5719748515cf/Downloads /home/gits/Downloads

But It fails, I don’t remember the error, since it was a week ago.