Missing build dependencies for kernel source

I’m trying to unpack and patch the kernel source RPM. I’m using yum-builddep to install the build dependencies and it fails to find several of them, including dwarves, libbabel-trace, and libbpf-devel. I tried enabling the Rocky-Devel repo but still no luck locating them.

(I’m trying to figure out why my IPv6 token isn’t getting used to build an address and figured I could inspect the kernel SLAAC code to understand what the real requirements are. When the documentation is lacking, I go to the source.)


[root@rocky ~]# dnf search dwarves
Last metadata expiration check: 1 day, 19:28:17 ago on Thu 05 May 2022 19:31:13 CEST.
===================================== Name Exactly Matched: dwarves ======================================
dwarves.x86_64 : Debugging Information Manipulation Tools (pahole & friends)
========================================= Name Matched: dwarves ==========================================
libdwarves1.i686 : Debugging information  processing library
libdwarves1.x86_64 : Debugging information  processing library

[root@rocky ~]# dnf info dwarves
Last metadata expiration check: 1 day, 19:28:24 ago on Thu 05 May 2022 19:31:13 CEST.
Available Packages
Name         : dwarves
Version      : 1.21
Release      : 0.el8
Architecture : x86_64
Size         : 118 k
Source       : dwarves-1.21-0.el8.src.rpm
Repository   : powertools

for that one enable the powertools repository.

[root@rocky ~]# dnf list *trace* | grep -i babel
libbabeltrace.x86_64                             1.5.4-3.el8          @baseos   
libbabeltrace.i686                               1.5.4-3.el8          baseos    
libbabeltrace-devel.i686                         1.5.4-3.el8          powertools
libbabeltrace-devel.x86_64                       1.5.4-3.el8          powertools

same for the babel one. Repeat using the commands above to search for the other deps that you need.

Thanks! That let yum-builddep run to completion and I was able to unpack/patch the kernel sources.

1 Like