Looking for advice for a LAN setup

I have a number of Rocky Linux workstations that I’d like to connect via a router.
With Windows it was relatively straightforward. I used TCP/IP4.
I’ve gone into nmtui and tried setitng up manual ip addresses.
When I try to ping one machine from the other I get : Network is unreachable.

Any tips on this. I don’t want to know everything about networks just how to set up something simple where the machines can see each other on the network.


1 Like

I realise that samba may be an option…but are there pro’s and cons to this?

1 Like

It might be helpful here if I explain. I just want these workstations to be able to access each other and a Synology NAS.

1 Like

If the router has a built in hub, instead of messing with network settings, you could just try plugging them in. Make sure you have the router manual, and know how to log into it’s web interface.

1 Like

Here’s a question, what are the IP addresses of the individual machines? Can they ping the router?

1 Like


Is firewalld enabled?

I believe this blocks pings by default.

How are you accessing the NAS on each device?

Regards Tom.

1 Like

The default zone is public and that has:

meta l4proto { icmp, ipv6-icmp } accept

(and no “icmp-blocks” listed in firewall-cmd --info-zone=public )

A typical home/consumer “router” has about four physical ports (and WiFi) and more importantly a DHCP server. The connections in Rocky do default to use of DHCP client.

That is, when one connects fresh Rocky to router, the Rocky shouts to wire and the DHCP server in the router hands it appropriate network configuration. Each new client (be it wired or WiFi) gets a unique IP address within the subnet that the DHCP server is set to serve. Plug-and-play.

Most such routers should offer a method to reconfigure the DHCP server to hand “static” address per MAC, i.e. have a MAC to IP lookup table so that you know which address the machines in the table always will get.

Doesn’t your router have such options?


Thanks for all the responses.

I temporarily disabled firewalld but still could not ping the Synology NAS.

I have a very simple router. It’s a D-link DGS-1005D.
It worked fine for years with Window’s workstations but maybe I need to upgrade it for Linux?

Any suggestions about good routers for this purpose?

1 Like

Is not a router. It is an unmanaged switch. So no DHCP in it.

The Windows do fall back to “zeroconf” when there is no DHCP nor manual config. They just pick unused address from – i.e. pick address from that range, shout to wire: “Does anyone has this?” and if nobody answers, then use the address.

One could set up DHCP server (dnsmasq) on one of the machines, but then it should be up whenever any other machine is up (if networking is required).

If you just set the addresses manually, then they should be on same subnet. For example, addresses for four machines:
1 Like

I’m unable to ping the NAS despite disabling firewalld and connecting the ethernet cable directly from the NAS to the back of my machine.

Any ideas what I might be doing wrong?



What IPs have you set on the NAS and the workstations?

Regards Tom.

The ip on the NAS is

The workstation is

I’m pretty green about a few things here…for instance why the /24 after the workstation ip?

In NMTUI I set the IPv4 config of the workstation to be When I run the command ip address though it returns

Maybe you can point out what I’ve done wrong here. My understanding is that IPv4 is simpler than IPv6?

Maybe you can point out what I’ve done wrong here.

You’ll need to learn the concepts of what comprises a home or small office network.

This section is intended as a primer for how to setup a home or small office network. [OpenWrt Wiki] Network Components

1 Like

You may be right but I was able to do this with Windows without a hitch. It worked for years!

Why for instance when I use nmtui to change the ip address on a PC and then I reboot and run ip address am I still getting the old ip address details?

In terms of network. It’s a simple peer to peer LAN with fixed ip addresses. I’m using a switch not a router. I’m not worried about internet connection - I’m using wifi for that. Nothing fancy.

The problem I’m having currently though is that I can’t successfully ping the NAS even though it’s plugged into the PC I’m working on and it has a fixed ip address and I’ve disabled firewalld.
Any ideas?

OK - some progress made. I can now get the Rocky Linux PC’s to ping each other through the switch. Still no joy with the NAS though…

This worked - thanks!

That isn’t going to work. Setting a mask of /32 means it’s a single IP address. Secondly, the IP of the NAS, what is it’s mask? If it’s also /32 then nobody will see that either. If you are networking everything, and using 192.168.1.x/24 (where X is a different number for each PC), then it will work. You will not see the NAS since it’s a totally different subnet and for that you need a router - which you don’t have. You just have a switch.

Since you a messing up the networking, as @ganphx said, you need to understand networking, since that would have helped you realise why different subnets cannot talk to each other. The same by allocating restrictive masks like /32, when the usual mask you would use at home is /24.

Cannot work, using the IP addresses you have listed here. Either that or the computers had both 192.168.1.x addresses AND 155.155.1.x addresses. In which case, you either need to pick and choose a single subnet or use both, and allocate multiple IP’s to your devices.

Also, using 155.155.1.x or 155.155.155.x is not a good idea, since these are IP addresses assigned to the internet space.

Read about private IP addresses to find out which ones you should be using: private ip address ranges - Google Search