Linux Newb - Losing Ethernet/Wifi connectivity

Having a bit of trouble, I am some what new to linux but I have some “computer” experience. I am having some problems with my newly installed setup, it appears that it is either suspending or going to sleep and I keep losing wifi/ethernet. I thought that I disabled sleep, but when I try to connect via CLI it says SSH port is closed. The computer is on and connected to ethernet, I just can’t get to it. Any help or a point in the right direction would be helpful.

Hi @gcache,
Do you have physical access to you computer, if yes then login physically and run following command to check your firewall status.

systemctl status firewalld

If firewall is running it will show some messages with some green text, in that case you need to open ssh port ( port 22).

Please share output for above command, and following command to further solve your problem:
ip add
ping -c 5 8.8.8.8
thanks :slightly_smiling_face:

● firewalld.service - firewalld - dynamic firewall daemon
Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: enabled)
Active: active (running) since Mon 2022-03-14 14:51:40 EDT; 40s ago
Docs: man:firewalld(1)
Main PID: 1196 (firewalld)
Tasks: 2 (limit: 408202)
Memory: 33.4M
CGroup: /system.slice/firewalld.service
└─1196 /usr/libexec/platform-python -s /usr/sbin/firewalld --nofork --nopid

Mar 14 14:51:40 BigDaddyServer systemd[1]: Starting firewalld - dynamic firewall daemon…
Mar 14 14:51:40 BigDaddyServer systemd[1]: Started firewalld - dynamic firewall daemon.
Mar 14 14:51:40 BigDaddyServer firewalld[1196]: WARNING: AllowZoneDrifting is enabled. This is considered an insecure configuration option. It will be removed in a future release. Please consider disabling it now.
~
~
~
[hoopie@BigDaddyServer ~]$ ip add
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp89s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
link/ether 1c:69:7a:ad:0e:e5 brd ff:ff:ff:ff:ff:ff
3: wlo1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
link/ether dc:21:48:46:29:4a brd ff:ff:ff:ff:ff:ff
inet 192.168.1.122/24 brd 192.168.1.255 scope global dynamic noprefixroute wlo1
valid_lft 86325sec preferred_lft 86325sec
inet6 2600:1700:2458:620::13/128 scope global dynamic noprefixroute
valid_lft 3526sec preferred_lft 3526sec
inet6 2600:1700:2458:620:94b1:89e4:e6e1:7c11/64 scope global dynamic noprefixroute
valid_lft 3527sec preferred_lft 3527sec
inet6 fe80::b5a1:cd5b:fcc5:6f7d/64 scope link noprefixroute
valid_lft forever preferred_lft forever
4: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
link/ether 52:54:00:a9:74:d5 brd ff:ff:ff:ff:ff:ff
inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
valid_lft forever preferred_lft forever
5: virbr0-nic: <BROADCAST,MULTICAST> mtu 1500 qdisc fq_codel master virbr0 state DOWN group default qlen 1000
link/ether 52:54:00:a9:74:d5 brd ff:ff:ff:ff:ff:ff
[hoopie@BigDaddyServer ~]$ ping -c 8.8.8.8
Usage: ping [-aAbBdDfhLnOqrRUvV64] [-c count] [-i interval] [-I interface]
[-m mark] [-M pmtudisc_option] [-l preload] [-p pattern] [-Q tos]
[-s packetsize] [-S sndbuf] [-t ttl] [-T timestamp_option]
[-w deadline] [-W timeout] [hop1 …] destination
Usage: ping -6 [-aAbBdDfhLnOqrRUvV] [-c count] [-i interval] [-I interface]
[-l preload] [-m mark] [-M pmtudisc_option]
[-N nodeinfo_option] [-p pattern] [-Q tclass] [-s packetsize]
[-S sndbuf] [-t ttl] [-T timestamp_option] [-w deadline]
[-W timeout] destination

Your firewall is running so run following command

firewall-cmd --list-all

If you will see ssh in service field then ssh is allowed but if it is not present the you need to create rule to accept ssh connection.

Please use following command to create rule

firewall-cmd --zone=public --remove-port=22/tcp --permanent
 
firewall-cmd --reload

Please share your status after applying above mentioned method.

It looks like the ssh rule is there

public (active)
target: default
icmp-block-inversion: no
interfaces: wlo1
sources:
services: cockpit dhcpv6-client plex ssh
ports: 4000/tcp 5353/udp 4011/udp
protocols:
forward: no
masquerade: no
forward-ports:
source-ports:
icmp-blocks:
rich rules:

The problem I am having is that sometimes after a while if I need to ssh into my machine, I have to hard restart it. It’s like the machine goes to sleep or something but I have it disabled or so I thought.

It may be a bios issue. Turn off all of the power saving settings and see if that fixes it.

The Intel NUC itself is still on though, I have disabled sleep etc. but if I don’t use it for a couple hours I have to come back and hard re-boot it for it to come up again. It shouldn’t be this hard though right?

Is the rest of the computer running other than the network? Can you just walk up to it and start using it?

Hi @gcache,

not sure if you generalized “NUC” as a synonym for any kind of tiny PC - or whether it indeed is an Intel NUC. If it is, then there’s lots of people complaining about that they can’t wake it from sleep. My gut feeling tells me that this is likely to be rather a BIOS issue than a driver, Linux related problem.

It may be worth checking, if any of the methods concerning BIOS does help:

Someone over at reddit (I know, I know…) wrote, in a response from about 1 month ago…:

Go to the BIOS settings and in the power settings change legacy s3 sleep to modern standby.
That did the trick for me (on NUC8I5BEH).

Other than that, Intel themselves have a couple of advice here.
I’d suggest however to use the BIOS update as a very last attempt, after trying everything else.

Hope this helps. Cheers,
Thomas

I am hoping that these settings work, I will follow back up on if I had to do a bios update if these settings don’t work

I may have found the actual issue, there was a reddit post that lines up exactly what I am now seeing with it plugged in and not running headless. It looks like the screen freezes and this happens - https://www.reddit.com/r/intelnuc/comments/qfj403/intel_nuc_nuc8i5beh_keeps_freezing_up_with_green/

Looks like it is potentially a BIOS issue or I need to move away from Rocky altogether as this keeps happening. I would prefer to run it in headless without having to constantly reboot it to get everything back up and running again. I am following a few posts in the Intel NUC forum and it is looking like it might be a BIOS update that they are waiting to put out.

1 Like