Linux kernel 6.x not vailable for Rocky on ARM (RPi4)?

I’m trying to set up a Raspberry Pi 4 with Rocky Linux 9 on kernel 6.x, and following some guides for setting up ElRepo for this purpose. However, I’m finding that none of the mirrors have the repodata/repomd.xml file for aarch64, so I’m guessing an ARM release for kernel 6.0 isn’t out yet?

I’m not very familiar with the RHEL/Rocky ecosystem, so forgive me if the above is obvious. But if it is indeed the case that kernel 6.x isn’t available on ARM, can anyone point me to any information regarding when that would be released?

You should ask from the maintainers of ELRepo whether/what plans or policy they have about aarch64.

Maybe you are looking at a stale mirror? For example, see here:

The kernel repo is not enabled by default. You either enable it or run yum/dnf with “–enablerepo=elrepo-kernel” .

Ah yes, that was the problem. I managed to install the 6.x kernel now, but after rebooting I’m still on 5.15:

[rocky@camilladsp ~]$ uname -r

I double checked that I didn’t miss any kind of boot menu, but there isn’t any choice displayed when booting up the RPi. How do I set which kernel should be booted when running on a Raspberry Pi?

Can you show us the output from:

rpm -qa kernel-ml*

[rocky@camilladsp ~]$ rpm -qa kernel-ml*

And when you saw the grub boot menu, you did not see “kernel-ml” ?

That’s very odd.

I didn’t see any grub boot menu at all, I’m not sure if that’s due to me being on a Raspberry Pi or not.

We need help from a raspi expert …

I’m now trying to reach @pgreco :slight_smile:

That’s excellent, I’m not sure what to do from here since there really doesn’t seem to be a grub menu at boot.

Ah, I see. No grub menu. This is a new “feature” with EL 9.1. You can disable it by running:

# grub2-editenv - unset menu_auto_hide

I tried grub2-editenv - unset menu_auto_hide, but there is still no grub menu displayed on boot.

Strange. Other methods include:

Hold the Shift key during boot
Press the Esc (or F8) key repeatedly

There are really no such boot options at all, the pi just boots directly into the OS without any interaction that I can see. I tried Esc and F8, but neither of them do anything.

How does RPi4 boot?

With UEFI? Does efibootmgr show “UEFI menu entries”?
If yes, then what efi-binary does it load?

I don’t think it has a BIOS or UEFI, there is no efibootmgr utility installed in the RPi image for Rocky.

The successful install of update kernel but running the old one and the mismatch output of

uname -r
rpm -qa kernel-ml*

Looks “similar” to my problem in below and the hint of @pedro help me out.

Hope that apart from “fighting” with the grub, @pedro hint may help you also.

if you want, try the latest generic aarch64 image from here, this one doesn’t depend on RPI kernel but uses 5.15 LTS kernel, you can then update it with elrpeo and see if this will boot

we are working on mainline streaming this effort as well, it has the RPI firmware baked into it

I installed one of the standard aarch64 images before I realized that there was a dedicated RPi image, it was the DVD one. But that image didn’t boot at all, so are you saying that the minimal one does boot on a pi?