Kickstart initrd

Hi All,

I am kickstarting Rocky 8.8 in Supermicro SYS-5019S-W4TR.

in PXE + tftpd + dhcp env

Loading images/vmlinuz… ok
Loading images/initrd.img… ok

System Reboots.
Not entering into Installer.

I tryed replacing the with Rocky 8.0 and Rocky 9.0 initrd.img file in PXE Server.

Starting Installer, one moment…

Service org.fedoraproject.Anaconda.Modules.Storage has failed to start: Failed to activate service ‘org.fedoraproject.Anaconda.Modules.Storage’: timed out (service_start_timeout=600000ms)

Pane is Dead (status 1, DATE).

How to handle this? any files to be added from 8.0 and 9.0 initrd.img to my current 8.8 initrd.img.

Sathiya Narayanan

What is the exact kickstart line you are using for this?

I was using the following kickstart …

label Rocky8.8
menu label Install NewRocky
kernel images/vmlinuz nomodeset
append initrd=images/initrd.img inst.ks=http:///ks/newrocky.cfg ip=eth0:dhcp ipv6.disable=1 net.ifnames=0 bootdev=eth0 inst.syslog= inst.text inst.resoulution=1024x768 nomodeset

Thanks. OK, and how do you have the url source defined in this config file?

What is the general layout of the source files and directories there?


There appears to be a group of (3) forward slashes in the url, is that correct? Typically it is (2).

1 Like

Hi , Looks like firmware issue in the initrd.img which we have.

Extracted the rocky 9 initrd image. consolidated the additional files from the initrd 8.8 + initrd 9.0. and kickstart worked.

now the server is up.

Thanks for your reply.

Sathiya Narayanan