Kernel panic when starting EuroLinux 9.2 installer

When running the EuroLinux installer, I get a kernel panic error.
What can I do to make the installation successful?

Kernel panic is not caused by:

  • incorrect distribution image,
  • I exclude RAM errors, because I tested MemTest86,
  • I exclude CPU errors, because I also performed stability tests,
  • exclude the size of hard drives, i.e. 2 with a capacity of more than 3 GB, because I tried to run the installer (LiveUSB, LiveDVD) also without hard drives.

Linux distribution:

  • EL-9-x86_64-latest-appstream.iso
    EuroLinux 9.2
  • EL-9-x86_64-latest-minimal.iso
    EuroLinux 9.2

Hardware requirements:
x86_64 (64 bit AMD/Intel architecture)

CPU Intel x86_64, AMD, ARM
RAM 4GB (1.5GB per CPU recommended)
Free space 10GB (20 GB recommended)

My hardware specs:

# lshw -c cpu
       description: CPU
       product: AMD Athlon(tm) 64 X2 Dual Core Processor 3800+
       vendor: Advanced Micro Devices [AMD]
       physical id: 3
       bus info: cpu@0
       version: 15.43.1
       slot: Socket 939
       size: 2010MHz
       capacity: 3GHz
       width: 64 bits
       clock: 201MHz
       capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt x86-64 3dnowext 3dnow rep_good nopl cpuid pni lahf_lm cmp_legacy 3dnowprefetch vmmcall
       description: CPU
       product: Athlon 64
       vendor: AMD
       physical id: 5
       bus info: cpu@1
       version: AMD Athlon(tm) 64 X2 Dual Core Processor 3800+
       slot: Socket 939
       size: 2010MHz
       capacity: 3GHz
       clock: 201MHz

As you can see there is apic. There is no acpi.
I tried to add the acpi=off option to GRUB when booting the installer. However, there is no difference - kernel panic in both cases.

MSI k8n neo4 - doesn’t support UEFI.

4GB, all 4 modules the same, manufacturer Kingston.

# lshw -c memory -short                                                                            0 < 23:16:27
H/W path              Device      Class          Description
/0/0                              memory         128KiB BIOS
/0/3/b                            memory         128KiB L1 cache
/0/3/d                            memory         512KiB L2 cache
/0/5/c                            memory         128KiB L1 cache
/0/5/e                            memory         512KiB L2 cache
/0/1e                             memory         4GiB System Memory
/0/1e/0                           memory         1GiB DIMM
/0/1e/1                           memory         1GiB DIMM
/0/1e/2                           memory         1GiB DIMM
/0/1e/3                           memory         1GiB DIMM
/0/4                              memory         Memory controller

I’m not going to remove this post in case someone knows anything and can offer support, but for next time I don’t think this forum is the right place to ask questions about EuroLinux.

1 Like

This CPU is very old. It is unlikely that it supports x86-64-v2. I would attempt to boot up any live image of any enterprise linux (rocky linux, alma, euro if they have it, etc) and verify it by running: /lib64/ --help

At the bottom of the output, you should see something like this:

Subdirectories of glibc-hwcaps directories, in priority order:
  x86-64-v3 (supported, searched)
  x86-64-v2 (supported, searched)

If x86-64-v2 does not show as supported, you will not be able to install nor run any Enterprise Linux 9 distribution (this means rhel, rocky linux, eurolinux, almalinux, oracle linux)


RHEL 9 (and hence its bug-for-bug compatible kin) does require the x86-64-v2: Building Red Hat Enterprise Linux 9 for the x86-64-v2 microarchitecture level | Red Hat Developer

The blog above and x86-64 - Wikipedia lists features required for x86-64-v2:

Athlon 64 X2 - Wikipedia list features in Athlon 64 X2 (Windsor):
… SSE3 …

The oldest Intel CPUs that support x86-64-v2 were released 2009. AMD a bit later.
That Athlon dates to 2006.


Agreed, this is Rocky Linux forum, not forum for Euro Linux. I couldn’t find a forum for Euro Linux, so I guess they only offer paid support. But I think @nazunalika and @jlehtone nailed it on the head with old CPU that isn’t supported.