Jfrog artifactory mirror Error with kickstart

Hello everyone,

I’m trying to install RockyLinux 8.5 with the Pxe method and with a kickstart.
It’s working fine for a minimal installation with internet repository ( …rocky/8/BaseOS/x86_64/os/ and repo Appstream ( …/rocky/8/AppStream/x86_64/kickstart )

Now, I created a mirror link of this repository on jfrog, updated the kickstart and it failed with this error :
“error setting up base repository”

For the source installation, i put this with the option noverifyssl :
https://user@password@my.jfrog.com/rockylinux8, mirror link of Index of /pub/rocky/8/BaseOS/x86_64/os/

I think that’s not an issue with jfrog, because :

  • Installation of Centos7 with this Jfrog is working fine.
  • I’m able to download metadata with yum (of dnf ) and install rpm with a repo file which content URL Jfrog on a RL8.

Any suggestion or experience to install RL8 with Jfrog ?

Thanks you.

Have you tried using the user and password options instead of putting them on the baseurl?


should be


look at the logs. go to tty1 (if you have local terminal) or ssh into anaconda (inst.sshd kernel argument, and there are also kickstart commands for setting the password or key) and have a look at anaconda.log (tmux window 3 with ctrl-b 3) or maybe program.log (tmux window 5 with ctrl-b 5). Also you could try manually with curl, you have a console on tmux window 2 (ctrl-b 2).


Yes, i tried it withtout success.


I’m going to test and give you a feedback.
I don’t thing so that’s an issue on Jfrog, but a mismatch configuration on the kickstart.cfg or on my Pxe configuration file.
I forget to tell you that’s during pxe process, i download the wmlinuz and the initrd.img from jfrog ( and for that’s, i have to add the option inst.noverifyssl


You have right, i did a mistake on my post, but the syntax of course is correct since the beginning.


I detect nothing of special, but i will post it as soon as possible, if it could help to debug.
Thanks at all for your reply.


After debuging, i found the reason.
To remind, i create a mirror link on jfrog, mirror of h.t.t.p.s.://my.jfrog.com/rockylinux8, mirror link of h.t.t.p.s.://download.rockylinux.org/pub/rocky/8/BaseOS/x86_64/os/

During, installation, it download correctly metadata on jfrog ( so from BaseOS/x86_64/os directory), and then i have the error “Error setting up base repository”.

On /tmp/packaging.log, i found this :
08:52:07,260 DBG packaging: releasever from https://user@passwod@my.jfrog.com/… is 8
08:52:07,260 DBG packaging: Adding new treeinfo repository: AppStream enabled: True
08:52:07,261 INF packaging: added repo: ‘AppStream’ - https://AppStream/x86_64/os
08:52:07,261 DBG dnf: repo: downloading from remote: AppStream
08:52:07,267 DBG dnf: error: Curl error (6): Couldn’t resolve host name for https://AppStream/x86_64/os/repodata/repomd.xml

The package download the treeinfo file from the repo, to determine the releaseserver (8) and try to found the appstream repodata, with a path indicate on it.
If it doesn’t, it use https://AppStream by default.

On the treeinfo, you have this section :
id = AppStream
name = AppStream
type = variant
uid = AppStream
packages = …/…/…/AppStream/x86_64/os/Packages
repository = …/…/…/AppStream/x86_64/os/

That’s incredible to not used the repo define on the kickstart ( repo --name=“AppStream” --baseurl=https://my.jfrog…), and try to found repodata of Appstream with “…/…/…AppStream/…”
My point of view, we don’t need to define repo --name=“AppStream” on the kickstart, because it’s never used during the installation. The Appstream repo is define with treeinfo, and if not accessible, replace by https://Appstream automatically.
Very strange.

My solution was to update mirrorlink with Index of /pub/rocky/8/, and put the path …my.jfrog.com/rocky8/BaseOS/x86_64/os/

Thanks you for the help, it’s solved for me.