Error setting up base repository in Rocky-8.8 with Kickstart

I’m Trying to make a custom Rocky Linux 8.8 Minimal iso with my custom packages. I’ve copied the content from anaconda-ks.cfg and I still get error setting up repository. the directory " /run/install/sources/mount-0000-cdrom/" seems to be empty when I boot up my custom iso. but when I boot up the original one. The directory is there and has all the iso files? I still cannot figure out what is the problem here or what’s causing this issue?

my kickstart file

# Use graphical install

repo --name="Minimal" --baseurl=file:///run/install/sources/mount-0000-cdrom/Minimal



# Keyboard layouts
keyboard --xlayouts='us'
# System language
lang en_US.UTF-8

# Network information
network  --hostname=localhost.localdomain

# Use CDROM installation media

# Run the Setup Agent on first boot
firstboot --enable

#ignoredisk --only-use=sda
# Partition clearing information
clearpart --none --initlabel

# System timezone
timezone America/New_York --isUtc

# Root password
rootpw --iscrypted $6$Kn9WX6S.6rI/fO4/$G11xEs4AtSSXbvlI84RGJkHoK.5bg9.dtNKYklmjZiPMUhO.M3hkQsX25JdERTgqgkdYw5we/JGvqjLUOwLd8/

%addon com_redhat_kdump --enable --reserve-mb='auto'


I’m a little confused - how exactly did you create this custom iso? It looks like all that happened is the default repo was deleted.

On a minimal install iso, the entirety of BaseOS is in that first repository, and anaconda will expect it to be there. The best way I know of to modify it is add additional repositories rather than modify default baseos.

I usually use the mkksiso tool myself.

I used genisoimage, I used this tool for Centos 7.9 last time. This is the exact copy of what was inside the anaconda.ks.cfg. I did a regular installation on a VM and copied the anaconda ks cfg. This was all written inside it. I did not modify the default repo?

I would suggest against using genisoimage just to add a kickstart. Use mkksiso instead to prevent accidentally damaging the ISO.

I was getting an error when loading the kickstart during the starting of installation.

Kickstart Loaded. Please re-insert the Installation media

for some reason the iso files were being unmounted? anyways
I added the following to my kickstart’s %pre section and everything worked like a charm

# Copy the contents from /run/install/repo/ to /run/install/sources/mount-0000-cdrom/
cp -ax /run/install/repo/* /run/install/sources/mount-0000-cdrom/

Thanks, this was resolved.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.