Inhibitor: Missing/Invalid PES data file (/etc/leapp/files/pes-events.json)

Dear All,
since today I’m experiencing issue during leapp preupgrade process from Centos 7.9 to Rocky Linux 8. At the end of the process I got

Inhibitor: Missing/Invalid PES data file (/etc/leapp/files/pes-events.json)

I have found info for RedHat website and tried also for my system but It doesn’t fix the issue.
Someone experienced such issue and could be share the experience

Upgrading from CentOS 7.x as far as I am aware is unsupported. The Rocky Linux migration script from what I remember only allowed migration from CentOS 8.

Best thing for you to do is make a clean Rocky installation, and migrate your data across from the old server.

@zanzi +1 to your issue. I’ve tried looking through logs both verbose and debug but there’s nothing available to actually see why leapp is failing. I think it’s going to require a code dive of the module to see what’s actually going on.

@zanzi so I’m not 100% sure that this issue is actually related to/becaues of Rocky itself. The crux of the issue is that in leapp-data-rocky-0.2-5.el7.noarch the JSON for /etc/leapp/files/pes-events.json went through changes from a json key perspective where keys were renamed from arches to architectures which I believe is the biggest breaking change. what’s interesting is the data in Github for the leapp-rocky-data RPM doesn’t match what version 5 of the package has other than the additional actions that were added to the events. It actually matches with version minus the additional actions. I’m unsure who actually maintains the leapp-data-rocky RPM but that’s the crux of the issue. I’m about to test if you utilize version 4 will it work (potential forwarding, a pre-upgrade with version 4 does work).

1 Like

I can now confirm that using leap-data-rocky-0.2-4.el7.noarch results in a successful upgrade.

1 Like

Upgrades are not supported. If you are using elevate, you will need to work with the maintainers of that product.

1 Like

@zanzi I have been facing the same issue since few days ago.

@Broosk Thank you!, I confirm the package “leapp-data-rocky-0.2-4.el7.noarch” works well. I could upgrade from CentOS7 to Rocky8.

sudo yum remove leapp-data-rocky
sudo yum install leapp-data-rocky-0.2-4.el7.noarch
sudo leapp preupgrade

This resolve my issue, thanks!!

1 Like

Thank you very much @Broosk nad @kobatarosan.

With the previous version of leapp-data-rocky 0.2-4 works.