How to install php7.2 on Rocky linux 9

dnf list php
only 8.0

i need 7.2;
I use compilation to install PHP, but OpenSSL3 version is not supported, and some other plug-in versions are not supported. My system is aarch64

Maybe you can try the REMI repository packages? Not sure. It is an idea to check out though.

I try the Remi repo, only x86_ 64 no aarch64

Sorry, I missed the aarch64 part.

Old versions of openssl are known to be weak, vulnerable and not worth the effort to fix; the latest versions of openssl are the fix. Software that depends on vulnerable components can turn out to have security vulnerabilities too. Therefore, you have to weight all the effort to find old PHP and cope with risks versus the effort to port your service to run on new PHP. Both hurt.

1 Like

None of the versions < 8.1 are compatible with OpenSSL 3 which is the default on EL-9.

My repository provides backports of the compatibility changes for 7.4 and 8.0 (and only for x86_64)

Notice that all version <= 7.3 have reached their end of life.
https://www.php.net/eol.php

So I recommend you use a supported version.
(of course you can try rebuilding .src.rpm from my repository, but only of 7.4+)

I don’t understand what this means?

Tries to get PHP installed by compiling/building it (from sources or srpm?), I’d guess.

If that’s the case, I don’t think the op would want an rpm version of php clashing with the compiled version.

sry

Compile PHP

i use php source
openssl3 is not support

i compile openssl 1.1.1k tips aarch64 is not support

Definitively, don’t try this…

If you really need 7.2, use EL-8

1 Like

i download all el8 rpm,
dnf -y install php*.rpm it,s work

Side note: “remi” now have aarch64 (only EL-9, only 7.4 to 8.1 as module)
See aarch64 repository for EL9 · Issue #214 · remicollet/remirepo · GitHub

2 Likes