Gdm doesn't start on boot

Hello team .

After removing old kernel versions from my RL 9, I jumped into an issue that I have tried to resolve for the better part of evening.

Gdm has completely failed to start . While I am able to get to the console with Ctrl+alt+f2 , I can’t do much .

Am getting the error gdm child process was already dead

on running the command

sudo systemctl status gdm

I even tried to reinstall the “Server with GUI” and setting
systemctl set default graphical.target

Either , I am unable to boot the system in recovery mode.

This is the screenshot

I am very scared not to lose this system as it is my production system.

Please help.

When you removed “old kernel version”, what else did you remove along with that?

/var/log/dnf.log will tell you.

Incidentally, removing old kernel versions is not something that most people would normally be doing. dnf.conf contains a parameter (installonly_limit) that allows you to determine the number of kernels that are kept after an update.

The logs from journalctl -u gdm might give a clue about the cause.