EFI Network boot failing to find files

Hi, I am testing Network booting EFI machines from my foreman/tftp server. I have chain load hd0 as the default in foreman’s global parameters and can see this reflected in my BIOS and grub2 grub.cfg files. In BIOS mode it works, in EFI I see the following message.

I’ve been searching around the internet and querying chatGPT, but I don’t think I’ve come across a discussion of anything exactly like this. My knowledge of grub is limited, so any help would be appreciated to steer me in the right direction.

I’m testing on a VMware VM in EFI mode with secure boot disabled. It’s a Rocky 9.2 image and the contents of /EFI/rocky and also /boot/efi/EFI/rocky:


Here are the 4 options I have to choose from and all fail. I’m assuming the chain option is correct since it works in BIOS.

I downloaded grubx64.efi from the rocky 9.2 repos and tried replacing what was created on the foreman server at /var/lib/tftpboot/grub2, but it was the same result.

Thank you for any assistance.