Pxe boot uefi mode

Hi everyone,

Without going into details at the moment, I can’t do PXE BOOT in UEFI MODE from a TFTP server with Rocky 8.5.

I receive this error :


I have tried to use initrd.img from 8.3 version but I have the same result.

My first question is whether Rocky is compatible with the PXE BOOT UEFI ?

My Grub menu :

linuxefi (tftp)/rocky85/vmlinuz ip=dhcp inst.repo=ftp://xxxxxxx
initrdefi (tftp)/rocky85/initrd.img


It is definitely compatible. I run UEFI PXE boot for Rocky and Fedora. I wrote this that shows how I set it up myself. If I had a guess, you may need to take off (tftp)/ on your linuxefi and initrd lines. Check the guide for more info and see below for my setup working.

Yes, Rocky is compatible with the pxe boot uefi. See the guide in the previous message.

Thank you for your answers and very nice guide!

After having made a few attempts, I still have the same problem.

I think the size of the initrd.img file might be the problem in connection with TFTP.

I tried :

-update grub tftp tftp-server syslinux vsftpd xinetd
-change server_args = -v --blocksize 16268 -s /tftpboot in xinetd.d/tftp
-change this config :sysctl -w net.core.rmem_max=26214400

I don’t have the problem with the initrd files of the centos and ubuntu distributions.

I’ll keep looking but if you have an idea.


having the same exact error. It seems that initrd.img is too big and download times out. Perhaps something to do with bug in Grub?:

Okay, figured that out. I was using old grub64.efi which had that nasty size bug.

1 Like

Hello Seitan,

I replace grubx64.efi → KO
I replace bootx64.efi (9.02MB to 1.24MB file for info (??)) and it’s ok now.

Tks for your answer !

I’m also had faced that same issue .After I copied the grubx64.efi file from Rocky ISO to directory of PXE Server /var/lib/tftpboot same has been resolved and Installation also get started.

Its Because of that old grubx64.efi file from your PXE Server .If you copy grubx64.efi from ISO file it will get resolved