Downgrading to Kernel 5.10.0 from 5.14 on Rocky Linux 9.1

Hello all,
For the past week I have been trying to downgrade my Kernel to Linux 5.10.0. I have been following the guide posted here:

I have followed every single step (many, many times) and when trying to load from the GRUB menu my system falls into an infinite “emergency mode” loop. There is an error at the top that states “Failed to lookup EFI Memory Descriptor 0x[whatever the address was, unimportant]”. In the config menu for the kernel, I have tried to enable all EFI options, including the fake memory address one, all ending with the same emergency loop result. I’m not the most experienced on EFI things but I know that I need this specific kernel version as some NVMe features were removed in newer versions. I have secure boot disabled on my device and my typical Rocky kernel (5.14.0-162.12.1.el9_1.0.2.x86_64
) boots perfectly. I have scoured the internet and have not been able to figure out anything… Someone please help!!!

@asnow That procedure should have had a warning at the top of it. That has been corrected now. In most cases, custom kernels for RL are not needed, and for most, not recommended. Take a look at the revised procedure with the warning at the top and see if you can use one of the alternative methods to get your system stable again. We are sorry that this warning was not included in the original procedure. Let us know how you get along.


Unfortunately, the kernel I am trying to install is not available from ElRepo. I’ll look into installing 5.10.0 using kmod/dkms, thank you for throwing that warning in there! I think that if I mess around with the kernel config some more before trying to install it I might have some more luck. Anyways, thank you again!


(I’m genuinely curious, although post requires 20 chars.)

The Linux Kernel 5.10.0 allows the user to properly run namespace commands for NVMe devices that utilize all F hexadecimal addresses. In newer versions of the kernel, this specific feature was removed for some reason unbeknownst to me. I installed Rocky 8.7 and was able to successfully upgrade the kernel to 5.10.0. I am now wondering if I would be able to upgrade this specific OS to Rocky 9, but retain the kernel version, since I wouldn’t necessarily be downgrading any longer.

You had custom kernel with Rocky 9 content and that combo did not run.
You have custom kernel with Rocky 8 content and that seemed ok.
You ponder what replacing the Rocky 8 content with Rocky 9 content would give you.
I’d guess: “custom kernel with Rocky 9 content”. Or a total mess.

Find out the reason. Find out whether any alternatives are offered.

I initially decided to not upgrade from 8 to 9, but I was going insane trying to figure out how to get the kernel. I eventually decided to upgrade as a “Hail Mary” shot, and believe it or not, it worked.