Display resolution issue / VGA driver

Hello I,m a newbie on Linux,
I just installed Rocky Linux 8 (8.1), i am using a 4K capable monitor but the only resolution available in the OS is 800x600, i want to use my hpe microsver gen10 as a desktop pc so i can learn to use Linux. Under the About menu i see that it is used some sort of software/generic video driver llvmpipe (LLVM 17.0.6, 256 bits) i think this could be the issue. I tried to install amdgpu but it seems that it is not working, i installed from the url Index of /amdgpu/latest/rhel/8.9/main/x86_64/ because the one from amd’s website points to an unavailable repo. lspci | grep VGA 00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wani [Radeon R5/R6/R7 Graphics] (rev 87)

I would need help how to debug my issue, what should i do next? Thanks

Ervin

Try one of the Live Desktop environments either for Rocky 8 or 9 here: Download - Rocky Linux (scroll down a bit)

I was not successful, i don’t get why were not booting in the GUI they stuck on loading.
But i tried with debian 12 and i had success everything out of the box is working so it stuck with this for now.

Thanks for the suggestions.