Device name changed after reboot jbob disk

Hi, guys

If you reboot after changing the sas disk to Job mode, the device name gets twisted.

This is the spec of the server I’m testing right now.

os= rocky 9.2
I put the scsi_mod.scan=sync option in grub in os.

For example, os disk = /dev/sda(reboot ->) /dev/sdc
Like this.

I really don’t know what the hell’s wrong with this, guys. Please save me

I want to solve it without uuid or mount or formatting.

Bless everyone who answered

This is why mounts using the UUID for the partition is the solution to the problem, when mount points or disks change position.

The solution is to use blkid to get the UUID and then use that in /etc/fstab. Why do you not want to use this method which is very easy to solve your problem?

thx, iwalker

I want to solve this problem through grub setting.
Is there only a solution through UUID?


At some point LABEL was also an option. Both UUID and LABEL are metadata stored within filesystem – inside volume – and hence persistent, unlike the enumerated /dev/sd* names.

Low level clone of disks and volumes duplicates some of PARTUUID, PARTLABEL, UUID, and LABEL but that is usually a different issue.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.