Copy files from Windows host to virtualized Rocky Linux OS on VMWare


I use to work on a VM with Red Hat 5 OS and copy files from my host (Windows 10) to the VM easily.

I have newly created a VM with the Rocky Linux OS installed on it. The issue is I am not able to copy files from my host (Windows 10) to the VM (Rocky Linux)



How did you copy to RHEL 5?

I did copy from Windows host folder and while RHEL5 is running as a VM launched by VMWARE, I went on RHEL5 and pasted the folder and it worked

When I try to do the same on Rocky Linux VM launched by VMWARE in /home/Username/Documents for example the “paste” option on right-click is blank as if the clipboard was empty

Try to use winscp to copy over ssh protocol.

@shalom could you please help on how to achieve this ? I did the below.
dans la VM Rocky Linux :
ifconfig ens33 netmask

then I launched Winscp and filled the form as following :

  • File protocol : SFTP
  • host name :
  • Port Number : 22 ( I let the default one)
  • User name : root
  • Password : [password]

and nothing happened…

i even tried to ping the IP from my host (Windows 10) and it didn’t work… :frowning:

Please run and command on in your VM and ipconfig/all command in your base machine and share screen shot.

It seems it is related to routing issue.

Ref: command used to list all ip address and network interface card.
command used to list all available routes in your VM.

@aembode if you check Host (windows 10) screenshot then you easily figure out that there is no interface assigned to same subnet means This is the main reason your not able to connect with your VM.

Please resolve your network adapter configuration.

@ aembode
Looks like you are usibg to GUI.
If so,
check: vmware tool installation / vswitch / VLAN ID / network ID
check: firewall rules or disable it.
check: lsof -nPi:ssh
option #1. To install FIleZilla client on Win. host.
option #2. To use a terminal shell then use sftp command-line.
options #3. To write a script.
options #4. SAMBA