Change keyboard Layout

Good day. I have a problem with switching the input keyboard now I switch keyboard layouts with the Alt + Shift key combination and I need Ctrl + Shift. How to change?

Hello @t-vex

if that for rocky 8 then go to setting → devices → keyboard → scroll down till you get to typing then change it as you like

for rocky 9 go to settings → keyboard → scroll down till you get to keyboard shortcut → typing then change it as you like

hope that help and have a nice day :slight_smile:

1 Like

Set rocky linux as default and then add a keyboard layout like french or lithuanian or russian and as you wrote change it to ctrl + shift and see if you can do it or not? I think you will crash.

@t-vex I’ve edited your post due to lack of respect to people helping you. If you want help on forums, respect the people who reply to you and are spending their own time attempting to help you.

In my VM I have attempted to change it from Super+Space to Alt-Shift and also Ctrl-Shift and it seems it’s not possible. Not sure if this is because it’s a VM, or because it’s not available as an option for that particular key sequence. Try using a different key sequence instead if the one you have attempted to use doesn’t work.

1 Like

thanks @iwalker

you can achieve that by installing GNOME Tweaks then open it then Keyboard & mouse → additional layout options → switching to another layout → check ctrl + shift

tested using rocky 8.6 and working fine


the visual effect when you switch keyboard would not show up but you can notice the keyboard icon on the top right corner switch as you press it

i did not tried it with rocky 9 so try it

Thank you kind person it worked out. God bless America.

The topic can be closed.

you welcome God bless you too but i am not American :joy: