After kernel update boot on grub prompt

I have a dell poweredge r610 on which is installed roky linux 9.4.
This server use megaraid_sas downloaded from elrepo:
https://elrepo.org/linux/elrepo/el9/x86_64/RPMS/kmod-megaraid_sas-07.727.03.00-1.el9_4.elrepo.x86_64.rpm
On the server there was installed kernel version 5.14.0-427.13.1
I executed dnf update command and kernel has been succesfully updated to version 5.14.0-427.22.1 but, after reboot it boot directly into grub prompt without receive any errors.
I tried a troubleshooting using a rocky linux live usb key and I recreate grub configuration file using this command:

grub2-mkconfig -o /boot/grub2/grub.cfg

from grub prompt I’m able to see disk and partition thant there is no issue with megaraid_sas kernel driver.
could you help me to understand this issue? where can I find boot logs to identify this problem?

Can you show us the output from:

$ find /lib/modules -name megaraid_sas.ko

and

$ sudo lsinitrd | grep megaraid_sas

I have no access on the shell, I’m able only to access on grub prompt.
however, the module is present on more kernel folder module, on old kernel it is present into
/lib/modules/5.14.0-427.13.1.el9_4.x86_64/extra/megaraid_sas/
instead into last kernel folder it is present into this path
/lib/modules/5.14.0-427.22.1.el9_4.x86_64/weak-updates/megaraid_sas/

This looks good. The driver is supposed to work with kernel 5.14.0-427.22.1.el9_4.

To run the lsinitrd command, boot the system with kernel-5.14.0-427.13.1 and then run as root:

# lsinitrd /boot/initramfs-5.14.0-427.22.1.el9_4.x86_64.img | grep megaraid_sas

the problem is that it doesn’t show me the boot menu, it enter direclty into grub prompt.
I can boot up only using usb live.
thanks
Ivan

I solved the problem in this way:

  1. loaded a rocky linux live from USB.
  2. loaded the megaraid_sas module and mounted the server disks
  3. run chroot on server disks and reinstalled the grub2 packages
    After reboot the server started succesfully.