Why not systemd-networkd? rant

Tried an upgrade Rocky 8.8 → 9.4
Almost everything worked fine, except that the upgraded box had no network.
Reason is of course the policy of putting a central element of the OS onto a more “obscure” package source aka Epel. I didn’t have the corresponding Epel sources ready at upgrade time, so no network afterwards.

Why? It should be in BaseOS.

Over the years I have battled many systemd gimmicks, I still hate it and it is no wonder that Poettering is working for M$.

But systemd-networkd is one of the best parts of it all!

Of course, starting with ifcfg-…, any networking config is better. But, honestly, NetworkManager? It is not even networkmanager, but capitalized, because someone thinks it is important?
Rocky could also adopt netplan, to point at more independence from Redhat, and to annoy more users.

Or is there a license issue with networkd? I mean, in the world of Rhel and Poettering - Linux, one cannot be sure whether installing GPL software doesn’t come with a fine…

Urgh netplan is worse than Network Manager. Network Manager once you get used to it is actually really good. But then everyone has their own perspective on what they like or don’t like.

Upgrades are not supported, and if you didn’t have EPEL 9 configured for the upgrade to pull in systemd-networkd then I’m not surprised it disappeared. The correct way is to reinstall your system and migrate your data across. Upgrades can be problematic, especially if you just upgrade without ensuring you have all the proper repositories configured in the first place. So the fact yours failed, you cannot blame Rocky or EPEL or Network Manager for it.

Rocky will not have netplan ever, because Rocky is 1:1 with RHEL. If RHEL include it, then Rocky will have it. I don’t even think it’s a viable alternative to Network Manager anyway.

Maybe systemd-networkd could be in BaseOS or AppStream, but that would need to be a request opened with Red Hat for them to add it. The fact it exists in EPEL means it can be used, but the problem occured here because you didn’t have EPEL configured when you upgraded…

1 Like