Upgrading packages, dnf error

Just had an odd experience with dnf. Checked for updates, and then started to upgrade all. First, there were a mirror link error, but after downloading all, and dnf started to upgrade/install everything - it ended with an error message that I needed a least 550MB more space in /.
Tried to upgrade a single package… Same msg, but now only 15MB needed.

My / (root) partition have 5.2GB available space, and my /var partition 5.1GB.

I guess my system cache was all filled up. Restarted the computer, and everything was fine. :crossed_fingers::+1:

Just found it odd with the (specific) message about /. Seems out of place, sort of. At least a bit misleading.

// Just wanted to share…

Disk space is one thing, inodes is another. You can have tons of disk space available, and yet not have enough inodes available. Had that once when a Debian system had exim installed but not running, and in it’s directories, there were thousands of files which ate up all the inodes. And yet, loads of disk space free…

To check available inodes:

df -i
1 Like

Aah, I see. Must’ve been the cache folder then that ha a lot of stuff.

Tested with that command now, and it seem like I have plenty left. But, good to know if it happens again. Thanks! :+1:

$ df -i --total -t xfs -t ext2
Filesystem             Inodes  IUsed    IFree IUse% Mounted on
/dev/mapper/rl8-root  7864320 268259  7596061    4% /
/dev/mapper/rl8-srv   2621440     20  2621420    1% /srv
/dev/mapper/rl8-var   5242880   4684  5238196    1% /var
/dev/mapper/rl8-home 19436712 179434 19257278    1% /home
/dev/sda2               65536    884    64652    2% /boot
total                35230888 453281 34777607    2% -
1 Like

A big update could easily use up the space. I had to move the dnf cache to a bigger drive once.

Naah, it wasn’t that big of an update. Maybe 20-25 pkgs or so. It wanted 550MB more space, so I guess about that size since it couldn’t even upgrade 1 single pkg.

Moving the cache… You mean setting the cachedir »»» in dnf.conf?

I’ve only used the makecache cmd a few times, but that’s all about the meta-data, right? Thought I could speed up dnf a little, but it didn’t change much. :slight_smile:

I’m betting on the cachedir having lots of small files eating up inodes, but if it happens again you can check/verify that with the command given previously before clearing everything.

If nothing else was done other than the reboot, then that is strange, since it would hint at some process that either thought it used all the disk space, or not enough inodes.

I just rebooted… :slight_smile:

I think maybe the system was all filled/clogged up by a lot of cache and tmp’s. The day before I spent a good amout of hours on Amazon, and almost “doom-scrolled” for some parts. Had to restart Firefox a couple of times, when it was almost in a freeze-like state.

I usually reboot my computer like every 3-5 days (or when I leave the house). It doesn’t have too much RAM, but the swapfile looked ok. It’s just an old laptop, so maybe it can’t handle too much.

Browser will have added to that then, here too lots of small files downloaded and cached, html, images, css, etc, etc. I’m going with lack of inodes :slight_smile:

Yes, probably, since I know I had the space. :+1:

Which I guess is also the (kind of) misleading part of the dnf msg. They specifically asked for N amount of more space, in X location.

Leaving it at “need more space” would be enough, and like more generic. Or maybe “Can’t allocate suffient resources to perform this operation”, for a more verbose (non-specific) msg.

1 Like

Yep, agreed. Would be better something like “out of disk space or inodes”, since I doubt very much there is another reason other than these two for the lack of space or inability to find free inodes.

1 Like

Yes, that’d be even better. :+1:



Did an upgrade today… There was about 90-100 pkgs to upgrade, incl new kernels. All went fine. :crossed_fingers: :+1: Ran the df -i ... cmd a few times during the upgrad - just to chk. It stayed at ~4% (IUse) on /.

Since I need to use the ElRepo kernel (my Wi-Fi is in there)… When there are kernels in the upgrade I always split the upgrade in two. Packages, and the kernels.

If it maybe helps someone… Here’s my upgrade strategy for that: :slight_smile:

sdnf chup

# No kernels in the list of upgrades
sdnf up

# With kernels in the list of upgrades
sdnf up -x kernel* -x kmod-kvdo

# Run new check, incl elrepo
sdnf chup --enablerepo=elrepo-kernel
sdnf up --enablerepo=elrepo-kernel

sdnf is a bash alias for sudo dnf
chup is a dnf alias added for check-update

It really helps getting a clean/better overview of what’s been upgraded/installed/removed. :crossed_fingers: :+1:

1 Like