I am trying to install a program (*.run)
and I have this error I don’t know where it comes from
anyone have an idea

./unix_installer.sh: line 1: python: command not found

can it come from there??

pip3 --version
WARNING: pip is being invoked by an old script wrapper. This will fail in a future version of pip.
Please see https://github.com/pypa/pip/issues/5599 for advice on fixing the underlying issue.
To avoid this problem you can invoke Python with ‘-m pip’ instead of running pip directly.
pip 21.3.1 from /usr/local/lib/python3.6/site-packages/pip (python 3.6)

thanks Dots

It would help to know what is this unix_installer.sh script, where did you get it from? And what is it for exactly?

Anyway, that aside, it cannot find python, which is why it is throwing up a problem. But to be honest, it would be best to know exactly what you are attempting to do, what are you trying to install. Because maybe a package already exists for it.

You shouldn’t download and run scripts without knowing what they are exactly going to do since you could be running something you don’t know, don’t trust, and have no idea what it will do to your system. Could even infect your machine with god knows what.

Bonjour iwalker

This is rendering software for Maya Arnold Render


it is software that I have installed several times already under Centos 7.9. I recently switched to Rocky 8.6 for a more modern Workstation

thank you

So you may need to check with them what versions of Python it supports. Also, what packages of python do you have installed? Post output of:

dnf list --installed python*

According to instructions here: Installing Arnold for Maya on Linux - Arnold for Maya User Guide - Arnold Renderer you need python2, so you can make sure that is installed with:

dnf install python2

as for the rest, it depends if it needs any particular additional packages, but then you can do:

dnf list --available python2*

to get a list of what extra can be installed if the script still doesn’t run. It also requires libstdc++ as per the install docs.

The only issue I see is they seem to prepare it for EL7, no mention that their package will work on EL8, so I’m wondering if they need to update and provide support for newer distributions.

Hi iwalker

I already have an older version installed which works fine,
I wanted an upgrade but I think I have to settle for this version

thank you for taking the time to look at my problem.

Yeah, sounds like the newer one requires some dependencies installing. Unfortunately, access to the downloads are protected by logins, so I cannot help figure out which ones you need.

You would need to pay attention to any output that you get to figure out what it’s wanting installed. Otherwise, you’ll need to contact them to improve their documentation to list exactly what packages need to be installed. For example, if python2 is installed and still doesn’t work, then it would be best if it explicitly mentioned the additional python packages/modules that are required. This is just an example, as it could be any other possible dependencies.

1 Like