Unable to install GDAL-Python

I tried several hours on the installation of GDAL-Python, however, so frustrated that I could not make it. Could someone help me?
I am using version 9.1

Here is about the gdal-python, Python bindings β€” GDAL documentation

I’m guessing that python3-gdal should be what you need. There are also other packages, see below:

[root@rocky9 ~]# dnf search gdal
Last metadata expiration check: 3:15:08 ago on Wed 19 Apr 2023 04:45:18 PM CEST.
========================== Name Exactly Matched: gdal ==========================
gdal.x86_64 : GIS file format library
========================= Name & Summary Matched: gdal =========================
OpenSceneGraph-gdal.x86_64 : OSG Gdal plugin
gdal-devel.x86_64 : Development files for the GDAL file format library
gdal-doc.noarch : Documentation for GDAL
gdal-libs.x86_64 : GDAL file format library
gdal-perl.x86_64 : Perl modules for the GDAL file format library
gdal-python-tools.x86_64 : Python tools for the GDAL file format library
python3-gdal.x86_64 : Python modules for the GDAL file format library

it should just need you to do:

dnf install python3-gdal

for example, or one of the other packages on the list. If that doesn’t help, please explain in more detail what you are trying to achieve.

3 Likes