[Testing] network.service not found


I tried to do systemctl restart network but service doesn’t exist. Is this missing on purpose?


You need to go with this :

systemctl restart NetworkManager.service

In CentOS/RHEL 8 the network services scripts are not presented anymore(systemctl start network.service or /etc/init.d/network script). In order to restart the network services follow the command from above.

You may need to ‘up’ NIC device in my experience (during building vagrant box)
onboot > yes (/etc/sysconfig/network-scripts/NET-DEVICE-NAME

I dont’ know why but default is ‘Down’ in my situation.
Hopefully it will help to you :slight_smile:

Hoon Jo

1 Like

/etc/init.d/network script doesn’t exist, and restarting NetworkManager service doesn’t help. Only ifdown and ifup works.

bytw, tried to pull your vagrant box 2 days ago but can’t boot it. I’ll spend some time this weekend and figure it out.

Oh really? I upload after testing…hmmm let me check it again.

It worked.

c:\HashiCorp>vagrant up
==> vagrant: A new version of Vagrant is available: 2.2.16 (installed version: 2.2.14)!
==> vagrant: To upgrade visit: https://www.vagrantup.com/downloads.html

Bringing machine ‘default’ up with ‘virtualbox’ provider…
==> default: Box ‘sysnet4admin/Rocky8’ could not be found. Attempting to find and install…
default: Box Provider: virtualbox
default: Box Version: >= 0
==> default: Loading metadata for box ‘sysnet4admin/Rocky8’
default: URL: https://vagrantcloud.com/sysnet4admin/Rocky8
==> default: Adding box ‘sysnet4admin/Rocky8’ (v8.3) for provider: virtualbox
default: Downloading:
==> default: Successfully added box ‘sysnet4admin/Rocky8’ (v8.3) for ‘virtualbox’!
==> default: Importing base box ‘sysnet4admin/Rocky8’…
==> default: Matching MAC address for NAT networking…
==> default: Checking if box ‘sysnet4admin/Rocky8’ version ‘8.3’ is up to date…
==> default: Setting the name of the VM: HashiCorp_default_1620200190691_30476
==> default: Clearing any previously set network interfaces…
==> default: Preparing network interfaces based on configuration…
default: Adapter 1: nat
==> default: Forwarding ports…
default: 22 (guest) => 2222 (host) (adapter 1)
==> default: Booting VM…
==> default: Waiting for machine to boot. This may take a few minutes…
default: SSH address:
default: SSH username: vagrant
default: SSH auth method: private key
default: Vagrant insecure key detected. Vagrant will automatically replace
default: this with a newly generated keypair for better security.
default: Inserting generated public key within guest…
default: Removing insecure key from the guest if it’s present…
default: Key inserted! Disconnecting and reconnecting using new SSH key…
==> default: Machine booted and ready!
==> default: Checking for guest additions in VM…
default: No guest additions were detected on the base box for this VM! Guest
default: additions are required for forwarded ports, shared folders, host only
default: networking, and more. If SSH fails on this machine, please install
default: the guest additions and repackage the box to continue.
default: This is not an error message; everything may continue to work properly,
default: in which case you may ignore this message.
==> default: Mounting shared folders…
default: /vagrant => C:/HashiCorp
Vagrant was unable to mount VirtualBox shared folders. This is usually
because the filesystem “vboxsf” is not available. This filesystem is
made available via the VirtualBox Guest Additions and kernel module.
Please verify that these guest additions are properly installed in the
guest. This is not a bug in Vagrant and is usually caused by a faulty
Vagrant box. For context, the command attempted was:

mount -t vboxsf -o uid=1000,gid=1000 vagrant /vagrant

The error output from the command was:

mount: /vagrant: unknown filesystem type ‘vboxsf’.

c:\HashiCorp>vagrant ssh
Activate the web console with: systemctl enable --now cockpit.socket

Last failed login: Sun May 2 12:55:43 KST 2021 from on ssh:notty
There was 1 failed login attempt since the last successful login.
Last login: Sun May 2 12:55:35 2021 from
[vagrant@SysNet4Admin ~]$ cat /etc/re
redhat-release resolv.conf
[vagrant@SysNet4Admin ~]$ cat /etc/redhat-release
Rocky Linux release 8.3
[vagrant@SysNet4Admin ~]$

1 Like

Hey guys, please dont mix the topics, for vagrant issue please open a new topic so I can get answers about my issue, thanks