System won't start. partition is full?

I can’t seem to find much information on this. When I installed Rocky Linux 8 on my system I knew I should have increased the root partition’s space and took some space away from /home but I didn’t. Well now I guess I’m paying for it. The system hangs up on boot and freezes. It doesn’t get to the login screen. In the past I have been able to get into a rescue mode, backup and delete the /home directory, resize the root partition, and replace the /home directory. That was when I had CentOS 6 installed on the system. I have since lost those instructions and cannot find them. Would something like this work on Rocky Linux 8? I would like to not have to reinstall the OS and start all over. I do not have a backup and not looking forward to having to set it all up again. Just looking for some guidance on how to get this thing to boot back up and add room to the partition. I have attached a screenshot of the partitions. Root partition is 35G of 35G used. I do not need all that room on /home. even if i can move half of it to the / directory would be great. Thank you in advance for any help that can be given.


Do you still have the install media? It can boot in rescue mode, where it also
mounts your filesystem(s) and then you can chroot in to do something.

I’d start with dnf --enablerepo= clean all to remove some cached files.

Note: on my desktop the root does not consume 30G:

$ df -h /
Filesystem      Size  Used Avail Use% Mounted on
/dev/nvme0n1p7   24G   13G  9.5G  58% /

I’d figure out where in ‘/’ the data is with ‘du’. For example:

# du -d1 -hx  /

I have a USB drive with Rocky Linux 8 installation files on it. I plugged it in and booted to it and got into rescue mode. I ran the dnf clean all command and it said it had removed 0 files. I ran the du -d1 -hx / command as you suggested and it came up with / having 2.8G but if i run df -h it shows / having 35G of 35G at 100%. not sure what is going on.