System Journal messages on console

Good morning everyone,
I installed two virtual machines using Rocky-9.2-x86_64-boot.iso
The two VMs have minimal resources: 1 vcpu, 1Gb Ram, 10G hard disk as they only serve as DNS.
Since I configured them I’ve been encountering this problem: in the console and in dmesg every 3 hours a message like this appears:
systemd-journald[6030]: Data hash table of /run/log/journal/848f1451c3d748dc92e54d8dcd77e36e/system.journal has a fill level at 75.1 (2594 of 3456 items, 1990656 file size, 767 bytes per hash table item), suggesting rotation.
[513498.378122] systemd-journald[6030]: /run/log/journal/848f1451c3d748dc92e54d8dcd77e36e/system.journal: Journal header limits reached or header out-of-date, rotating.

I’ve already searched a lot on the internet, I tried to change the parameters in /etc/systemd/journald.conf by setting

But the problem persists
Has anyone had the same problem?
Do you have any suggestions on how to at least prevent the report from ending up in the console and in dmesg?

Thanks in advance to everyone

Memory requirement listed for RHEL 9 (and hence Rocky 9):

1.5 GiB for local media or NFS network installation, 3 GiB for HTTP(S) and FTP network installation

That does not say much about the normal runtime of the system; it only tells something about one application (the Anaconda installer).

The systemd-journald does not write to disk by default. It only keeps log on tmpfs, i.e. RAM.
The man journald.conf mentions more than just SystemMaxFileSize and RuntimeMaxFileSize.
Could it be one of those other “Max” settings (that the 1GB RAM makes small)?

The log message does also point to number of entries rather than size.

you can set the virtual machine ram size with gui.
if you like, can edit the virtual hardware settings based on respective files:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.