Support UEFI boot in ibvirt-manager

I’m struggling to get homeassigant.qcow2 to bootup. Apparently this KVM image needs firmware UEFI x86_64 configuration to boot. I’m running Rocky 8.6 with the default QEMU/KVM. I’ve tried all the available firmware options. It just won’t bootup the homeassistant.qcow2 image. It’s there any upgrade of Rocky or QEMU/KVM to solve this problem?

Try installing:

dnf install edk2-ovmf

perhaps you don’t have this installed? This provides the ability to boot UEFI for KVM/QEMU.

thanks for your reply.
Yes, the package is installed.
pls see below…
Last metadata expiration check: 0:00:38 ago on Tue 18 Oct 2022 10:00:38 AM EDT.
Installed Packages
Name : edk2-ovmf
Version : 20220126gitbb1bba3d77
Release : 2.el8
Architecture : noarch
Size : 12 M
Source : edk2-20220126gitbb1bba3d77-2.el8.src.rpm
Repository : @System
From repo : appstream
Summary : UEFI firmware for x86_64 virtual machines
License : BSD-2-Clause-Patent and OpenSSL
Description : OVMF (Open Virtual Machine Firmware) is a project to enable UEFI
: support for Virtual Machines. This package contains a sample
: 64-bit UEFI firmware for QEMU and KVM.

Have you tried it on Rocky 9 which has newer KVM packages? Just in case it’s related to this. What does it say on the HomeAssistant website on how to use their image?

I had UEFI-mode VM on CentOS Linux 8 host before we even knew it won’t last, so the host-side ought to be ok, be it 8 or 9.

I saw number of HomeAssistant users are having the same issue. One user suggested to downgrade it to the OVMF-20150414-2.gitc9e5618.el7.noarch. I’ve tried to do the downgrade on my Rocky system. I was unable to downgrade to the version suggested. I didn’t want to break my system for the app. I saw success with other users on other distro. Not sure what’s the difference. It’s a whole log of afford to upgrade my system to v9 for the app. I’d like to keep my system running for a while yet.

You can definitely create vm guests with UEFI and secure boot on Rocky 8.5 and above (host and guest).