Some apps in flatpak are no longer working properly


Using Rocky Linux 8.9.

In recent days, some apps in flatpak are no longer working properly (they used to work fine) and do not show their window / GUI properly - eg some of the GUI has black rectangles in it. The GUI does not respond to mouse clicks sometimes. Also they are intermittently taking 100% CPU processing.

An example app that is having this issue is flatseal.

Over time more and more apps stop working. For example, Shortwave app started to have these issues this morning.

Rocky just did another update so I am wondering if updates are causing things to break.

I have posted this issue at flatpak but was not able to resolve it and there it was suggested I ask at Rocky forum:

Any help much appreciated. Please let me know if I can provide further info.

What was updated on your system at this point? You say Rocky did another update, but what was actually installed? New version of flatpak? Something else?

TBH, and as far as I am aware, the whole idea of flatpak, like snap, was making apps available irrespective of the underlying operating system. The apps are self-contained, providing their own dependencies - meaning that pretty much nothing from the OS side is depended on.

I very rarely install anything on flatpak, basically because I prefer the packages to be installed from the OS repositories. There are maybe one or two apps I use because I cannot find them anywhere else except in flatpak. Like MS Teams for example.

It would be better to run the app from a console window and then see what output is generated there. Usually you would have to report the problem with the person who created the app on flatpak in the first place for them to fix it if their app stops working due to high CPU usage, etc. I don’t really see how this can be a Rocky problem, when the app has come from flatpak.

@RL1000 Can you share an image of what you are looking at with an app that isn’t displaying the way it should? I’m suspecting (as I believe @iwalker is that this is something else. Perhaps a font display issue.

@iwalker - Thank you for replying. Just to be clear, I don’t mean in any way to blame Rocky for this - if my post came across like that, I didnt mean to :slight_smile:
I am just a home user of Rocky workstation, so I am not sure how to list what was recently updated, etc, but I will try to find out.
I do agree that Flatpak apps are self-contained, but flatpak itself still needs to run in the OS, IMO, and therefore dependent on the OS.
I try and minimize the use of flatpak apps as well. Like you I always try to find something in the Rocky repos first.
I tried to run flatpak in a terminal window and got the same result.
IMO I dont think it is an issue with a particular app, because now this issue is happening with most of the flatpak apps I have. IMO it is an issue with flatpak itself. So I dont think I should report this to the developers of each app.

@sspencerwire - Thanks for helping out. I tried to do a screen capture of Flatseal, a flatpak app that manages the apps.
LOL, it started up, took up my whole screen, which was pure black, other than one graphic in the top middle, some lines on the right side of the screen and my mouse cursor. It even blacked out my Gnome taskbar, so I could not access my shortcuts to start other apps. It took up 100% cpu, to the point I could not even move my mouse cursor and so I could not start my screenshot package to take a screenshot. Then it crashed, giving me use of Gnome shell again.
I will try some more though…maybe another app wont be as bad.

@sspencerwire - I managed to get a screen cap of Eyedropper:

Screenshot from 2023-12-18 17-40-54

This is what it normally looks like:

The thin lines around the black rectangle is the color and contents of my normal Gnome shell window.

It crashed shortly after I could take the screenshot.

Other flatpak apps show a similar GUI - mostly black with some objects of the app GUI shown…

I was wondering it has something to do with Wayland so I ran in CLI:

flatpak run --socket=wayland com.github.finefindus.eyedropper

and have the same issue…


flatpak run --socket=x11 com.github.finefindus.eyedropper

and have the same issue…

Something just popped a lightbulb in my head, I think I might know what you can do here. I think most flatpak apps will be under /home/username/.var where username is your user.

When in your home directory, do something like this:

cd .var
find ./ -iname gpucache

those are just results on my system, but see if you have a GPUCache directory under any of the apps you are having problems with. If you are, then delete the GPUCache directory. Using Postman as an example from my results:

cd app/com.getpostman.Postman/config/Postman
rm -rf GPUCache

then run the app and see what happens. If there is more than one GPUCache like I have with MS Teams, delete both of them.

I have this problem sometimes with MS Teams which from my results above is a flatpak app, and I have to do this when it doesn’t load properly. I later created a script for this to save myself having to do it manually:

# Remove cache directory to fix Teams issue

rm -rf .var/app/com.github.IsmaelMartinez.teams_for_linux/config/teams-for-linux/Partitions/teams-4-linux/Cache
rm -rf .var/app/com.github.IsmaelMartinez.teams_for_linux/config/teams-for-linux/GPUCache

I also sometimes have this with upgrades of Brave Browser, even though it’s not a flatpak app on my system, but it does have a GPUCache directory underneath. A terminal app I use called Tabby has also had the same problem.

I at least hope that will resolve your problem.

@iwalker - Thanks very much for suggesting that - I will try it and report back…

Thanks again for your suggestion and I did try this.

My result was that I found:

./app/net.xmind.XMind/config/Xmind/Electron v3/GPUCache

These were actually apps I had no longer installed.

I did delete the GPUCache directories.

Unfortunately this didnt resolve my issue.

I have discovered I can use “flatpak repair” but which also has some issues, which I have posted about on flathub:

Thanks though for your time and suggestions for my issue :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.