[solved] Ocsinventory-agent for Rocky Linux 8

Hello @all!

Today I had to install new machines with Rocky 8. Version 8 because of some software, that is not tested on Version 9 yet.
My problem now: I am not able to install the ocsinventory-agent for Rocky 8. I Used the steps described in Setting up OCS Inventory Server with RPM - OCS Inventory Documentation (of course for Enterprise Linux 8 (with EPEL and Remi) x86_64)

I can install ocsinventory-release, but not the agent. The agent wants to have perl-Data-UUID, but perl-Data-UUID needs glibc 2.34 but Rocky 8 has this only in version 2.28.

Any ideas how to install the ocs-agent? :slight_smile:

edit: solved, thank you very much, great forum! :slight_smile:

Perl-Data-UUID installs fine on my Rocky8 install, you have to use the one from powertools repository, so if you didn’t enable powertools repository, then do this and install. Not sure otherwise where you are getting this package from?

dnf config-manager --enable powertools

or alternatively:

crb enable
1 Like

Thank you very much! :slight_smile:
Problem is solved!

These are my steps now:

dnf config-manager --set-enabled powertools
wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-8.noarch.rpm
wget https://rpms.remirepo.net/enterprise/remi-release-8.rpm
wget https://rpm.ocsinventory-ng.org/ocsinventory-release-latest.el8.ocs.noarch.rpm
dnf install ocsinventory-release-latest.el8.ocs.noarch.rpm epel-release-latest-8.noarch.rpm remi-release-8.rpm
dnf install ocsinventory-agent

Rocky has ‘epel-release’ and dnf can use URL. Hence an alternative:

dnf config-manager --set-enabled powertools
dnf install epel-release
dnf install https://rpms.remirepo.net/enterprise/remi-release-8.rpm
dnf install https://rpm.ocsinventory-ng.org/ocsinventory-release-latest.el8.ocs.noarch.rpm
dnf install ocsinventory-agent
1 Like

Hi jlehtone

Thank you for your answer. Your alternative looks pretty nice! :slight_smile:
I will give it try on the last Rocky8 machine thumbsup