[SOLVED] No more start after kernel upgrade to rocky linux 8.5

after linux upgrade to 8.5 kernel (4.18.0-348.12.2.el8_5) my server dell poweedge R610 no more start, but it continue to start with old 8.4 kernel (4.18.0-305.19.1.el8_4).
During startup I receive this errors:

[TIME] Timed out waiting for devices dev-mapper-rl\x2dswap.service
[DEPEND] Dependency failed for Resume from h... using device
[ OK ] Started Dracut Emergency Shell.
[377.710009] dracut-initqueue[543]: Warning: Not all disks have been found.
[  OK ] [377.719919] Started dracut initqueue hook.dracut-initqueue
[543] Warning: You might want to regenerate your initramfs.
[   **] A start job is running for dev-mapp...root.device (31min 26s / no limit)

I tried to remove and reinstall last kernel without any success, could you help me to understand this issue?

Does it have hardware that needs drivers? Such that you have installed for 8.4, but forgot for 8.5?

I configured a dell repository (Index of /repo/hardware/dsu/os_independent) on my yum repos. And I saw that last package has been installed:

[root@mail ~]# rpm -qa dell\*

the disk drivers should be these one:
and it seems that they are related to linux 8.4, do yu know if there are new versions of these drivers?

I found the driver into ELRepo repository that wasn’t installed on my server. I’m installing it. I let you know if it solve the problem.

OK, in this way I solved the problem. thanks a lot.