Rocky Migration Script Hangs

Up until about a week ago, the migration script had worked rather well. The last three centos 8.4 to rocky 8.4 migrations all hang at or near reinstalling the third item. The latest attempt hang at [3/1174]. The file varies, but in this case it is filesystem-3.8-3.el8.x86_64. There is nothing special about any of these virtual machines, one is a file server the other a web server.

Is anyone else experiencing this issue? Do you have a work-a-round to offer?

Thank you in advance.

Running transaction test
Transaction test succeeded.
Running transaction
  Running scriptlet: filesystem-3.8-3.el8.x86_64                                                                                                              1/1
  Running scriptlet: fapolicyd-1.0.2-6.el8.x86_64                                                                                                             1/1
  Preparing        :                                                                                                                                          1/1
  Running scriptlet: libgcc-8.4.1-1.el8.x86_64                                                                                                                1/1
  Reinstalling     : libgcc-8.4.1-1.el8.x86_64                                                                                                             1/1378
  Running scriptlet: libgcc-8.4.1-1.el8.x86_64                                                                                                             1/1378
  Reinstalling     : fontpackages-filesystem-1.44-22.el8.noarch                                                                                            2/1378
  Reinstalling     : tzdata-2021a-1.el8.noarch [=========================================                                                             ]    3/1378

Always hangs at 3/XXXX or 5/XXXX and the file varies. Any thoughts would be great. I have had to rebuild three systems from scratch since the migration script isn’t working for me. Thank you.

Log your issue here Issues · rocky-linux/rocky-tools · GitHub so the devs can look into it. As always add as much detail as possible to assist with tracking down the problem.


I figured out the cause and work-a-round. I had hardened the CentOS8 system with CUI using scap-security-guide. After some trial and error, the work-a-round is simple. Stop the fapolicyd service.

systemctl stop fapolicyd
chmod +x
./ -r
dnf reinstall fapolicyd

The systems where the CUI scap-security-guide was not implemented worked successfully with

Checking the status of fapolicyd revealed problems, but the reinstall of fapolicyd resolved them.