Rocky Linux on Oracle VirtualBox consistently freezes after a short period of inactivity

I’ve just installed Rocky Linux on Oracle Virtual Box

System info:

$ uname -a
Linux RockyLinux.myguest.virtualbox.org 4.18.0-513.11.1.el8_9.x86_64 #1 SMP Wed Jan 10 22:58:54 UTC 2024 x86_64 x86_64 x86_64 GNU/Linux

After a few minutes the system becomes unresponsive. Using journatctl I can see "unchecked MSR access error"s:

Feb 13 18:30:53 RockyLinux.myguest.virtualbox.org kernel: unchecked MSR access error: WRMSR to 0x2ff0 (tried to write 0x0000000020000000) at rIP: 0xffffffffa4676294 (native_write_msr+0x4/0x>
Feb 13 18:30:53 RockyLinux.myguest.virtualbox.org kernel: Call Trace:
Feb 13 18:30:53 RockyLinux.myguest.virtualbox.org kernel:  ? ex_handler_wrmsr_unsafe.cold.2+0x2e/0x3d
Feb 13 18:30:53 RockyLinux.myguest.virtualbox.org kernel:  ? fixup_exception+0x33/0x46
Feb 13 18:30:53 RockyLinux.myguest.virtualbox.org kernel:  ? gp_try_fixup_and_notify+0x1b/0xa0
Feb 13 18:30:53 RockyLinux.myguest.virtualbox.org kernel:  ? do_general_protection+0xba/0x280
Feb 13 18:30:53 RockyLinux.myguest.virtualbox.org kernel:  ? update_load_avg+0x7e/0x710
Feb 13 18:30:53 RockyLinux.myguest.virtualbox.org kernel:  ? general_protection+0x1e/0x30
Feb 13 18:30:53 RockyLinux.myguest.virtualbox.org kernel:  ? native_write_msr+0x4/0x20
Feb 13 18:30:53 RockyLinux.myguest.virtualbox.org kernel:  adl_uncore_msr_init_box+0x27/0x30 [intel_uncore]
Feb 13 18:30:53 RockyLinux.myguest.virtualbox.org kernel:  uncore_box_ref.part.24+0x9c/0xc0 [intel_uncore]
Feb 13 18:30:53 RockyLinux.myguest.virtualbox.org kernel:  ? uncore_pci_pmu_unregister+0x90/0x90 [intel_uncore]
Feb 13 18:30:53 RockyLinux.myguest.virtualbox.org kernel:  uncore_event_cpu_online+0x52/0x1b0 [intel_uncore]
Feb 13 18:30:53 RockyLinux.myguest.virtualbox.org kernel:  ? uncore_pci_pmu_unregister+0x90/0x90 [intel_uncore]
Feb 13 18:30:53 RockyLinux.myguest.virtualbox.org kernel:  ? sort_range+0x20/0x20
Feb 13 18:30:53 RockyLinux.myguest.virtualbox.org kernel:  cpuhp_invoke_callback+0x8e/0x510
Feb 13 18:30:53 RockyLinux.myguest.virtualbox.org kernel:  ? sort_range+0x20/0x20
Feb 13 18:30:53 RockyLinux.myguest.virtualbox.org kernel:  cpuhp_thread_fun+0xb4/0x110
Feb 13 18:30:53 RockyLinux.myguest.virtualbox.org kernel:  smpboot_thread_fn+0xb5/0x150
Feb 13 18:30:53 RockyLinux.myguest.virtualbox.org kernel:  kthread+0x134/0x150
Feb 13 18:30:53 RockyLinux.myguest.virtualbox.org kernel:  ? set_kthread_struct+0x50/0x50
Feb 13 18:30:53 RockyLinux.myguest.virtualbox.org kernel:  ret_from_fork+0x1f/0x40

Any recommendations solving this problem?

You have provided very little information about your overall configuration i.e.

  • is this on an Intel of AMD system?
  • what version of VirtualBox is this?
  • what is the host OS and version?
    • if Windows, have you disabled Hyper-V?
  • is the guest OS Rocky Linux 8?
  • have you tried creating and running VM’s of any other OS, such as another linux and/or Windows?

I used Oracle VirtualBox for many years, when I was forced to run Windows at work but unable to purchase or use VMware Workstation due to organizational policy. It actually worked quite well for me, overall, until release 6-something, at which point I started having VM crashes, hangs, and instability issues seemingly out of nowhere. It was unfortunate, but later updates to VB6 often seemed to cause more issues than they fixed…

While I haven’t personally used VB in a couple of years now, I’ve seen numerous posts about VB7 being incredibly buggy and unstable, regardless of the host OS used. There also are specific issues reported about it not working correctly with later linux kernels, regardless of the distribution used.

As this question is rather VirtualBox-specific, I would recommend you visit their own forums to see if you can’t find an answer more quickly.

Offhand, the things I would check are:

  • are you using the latest-available version of VirtualBox on the host?
  • have you installed the corresponding VirtualBox guest additions in the VM/guest?
    • this actually is rather important; fixes many known guest issues
  • try changing the number of CPU cores i.e. if 1 now, try setting it to 2, and vice versa

In any case, hope this helps. Good luck!

1 Like