Rocky Linux 9.4 KDE: disable standby mode after 5 minutes?

Hi,

I just installed a vanilla Rocky Linux 9.4 KDE desktop using the corresponding Live ISO.

One thing that’s puzzling me: the desktop goes to sleep after five minutes of inactivity or so. Meaning when I SSH into the machine and do some work on it, I suddenly get disconnected after five minutes.

Does anyone know how to turn this unnerving feature off?

Cheers,

Niki

You might try checking to see if your dpms is enabled. You can check that with this:

xset -q

and see near the bottom the status, or someone in debian made a handy little bash script i saved a few years ago for the same reason:

xset -q | awk '/DPMS is/ {print $NF}'

then if you want to turn off energy star stuff you can use xset -dpms, and if later you want to re-enable it you would want to type xset dpms

I hope this works for plasma/kde, i know for sure it works for gnome - also you could try caffeine application, or see if there’s a way to enable “presentation mode” for KDE. I’m unsure how to do this in Rocky 9/KDE tho the xset should be relevant/work

1 Like