Rocky LInux 9.3 amavisd fails to start, failed with result 'exit-code'

I have a fresh install, following the “Perfect Server – CentOS 8” instructions for ISPConfig. There were no issue installing or configuring amavisd-new, spamassassin, clamav-*, postgrey, etc - followed the instruction and there were no errors - all other services start without issue. The instructions work just fine for CentOS 8 as well.
However, I’m getting an error trying to launch amavisd:

[root@mail bin]# systemctl start amavisd.service
Job for amavisd.service failed because the control process exited with error code.
See "systemctl status amavisd.service" and "journalctl -xeu amavisd.service" for details.

[root@mail bin]# systemctl status amavisd.service
× amavisd.service - Amavis mail content checker
     Loaded: loaded (/usr/lib/systemd/system/amavisd.service; enabled; preset: disabled)
     Active: failed (Result: exit-code) since Sat 2024-01-20 09:36:48 EST; 1s ago
       Docs: http://www.ijs.si/software/amavisd/#doc
    Process: 6117 ExecStart=/usr/sbin/amavisd -c /etc/amavisd/amavisd.conf $ARGS (code=exited, stat>
        CPU: 365ms

Jan 20 09:36:48 mail.example.com systemd[1]: amavisd.service: Scheduled restart job, restart counte>
Jan 20 09:36:48 mail.example.com systemd[1]: Stopped Amavis mail content checker.
Jan 20 09:36:48 mail.example.com systemd[1]: amavisd.service: Start request repeated too quickly.
Jan 20 09:36:48 mail.example.com systemd[1]: amavisd.service: Failed with result 'exit-code'.
Jan 20 09:36:48 mail.example.com systemd[1]: Failed to start Amavis mail content checker.

I did a little digging, and in the past, people found that the “myhostname” section of the amavisd.conf file needed a FQDN to work - mine already has that. I’ve not found any other references for a cause.

# OTHER MORE COMMON SETTINGS (defaults may suffice):

$myhostname = 'mail.example.com';

anyone else have any thoughts on what might be causing the failure to launch?
Thanks.

so I found this error in the messages log file:

Error reading config file "/etc/amavisd/amavisd.conf": Permission denied at /usr/share/perl5/vendor_perl/Amavis/Conf.pm line 1995

looking at my CentOS 8 system, it has permissions of

-r-------- 1 root root 34463 Nov  1  2022 amavisd.conf

while the new RL9.3 system has

-rw-r----- 1 root root 34465 Jan 19 02:09 amavisd.conf

i did a “chmod 400” on the file, and tried restarting, and got the same error.
I also compared the amavis/clam groups on the CentOS 8 machine with the RL9.3 machine, and they are the same as well.

well, this is annoying.
i removed amavisd-new, rebooted, reinstalled it, only edited the “LocalSocket /var/spool/amavisd/clamd.sock” line of the /etc/amavisd/amavisd.conf file, and then restarted amavisd without an error. I just used “mail” and “mutt” to send out messages from the command line, and both of them went through. So not sure what the problem was, but it appears to be working now.
Thanks for the help. Until I get this set up with real DNS entries pointing to it, i can’t test it fully, but looks like it’s working.