Rocky Linux 8 image in Azure problems

I just started using Azure and have provisioned about half a dozen Rocky Linux 8 servers and all of them provisioned fine. Last one I provisioned was last night and it was fine. I just tried provisioning a new server again, 3 different times. All of them using the same Rocky Linux 8 - Official from The Rocky Enterprise Linux Inc image. And each of them that are provisioned come up as Rocky Linux 9 and are having really weird performance issues. Was there a mistake in the build process that overwrote the good image with a beta of RL9?

Hello - Apologies for this. It appears I accidentally put both images in the same offer. I’ve started a rollback of the rocky 8 image, and am working on publishing the 9 image in a separate offer. I apologize for any inconvenience.

I think it may be possible to manually select the rocky 8.6.0 version of the image which is available in the offer, still.

No worries. At least we know what happened. Just update when it’s rolled back. Thanks for all your hard work.

If a clean build of Rocky Linux 9 is having performance issues on Azure, it would be good to know why.

The machines were already deleted, but I was only able to connect to 2 of the three. After a few minutes I lost connection and couldn’t reconnect. So unfortunately I can’t get any diagnostics.

I am interested to find out how the Rocky/Azure images are created. Is there a repo with the code that I could look at?

The Azure Kickstart can be found here: kickstarts/Rocky-9-Azure.ks at r9 - kickstarts - Rocky Enterprise Software Foundation Git Service – Beyond this, there’s only some light modification of the image to make it work in azure, which can be see in our toolkit, here: toolkit/ at devel - toolkit - Rocky Enterprise Software Foundation Git Service

We process this through Imagefactory at the moment using our homebrew toolkit called Empanadas… it does the composes (creating releases from Koji and Peridot), as well as image building to try and proceduralize it a bit more.

Imgfactory is a bit clunky for what we’re doing and I’d like to ultimately replace this with simply doing dnf --installroot or using something like mkosi (which does this under the hood).

All this to say… Myself and @lumarel have been doing some thinking on how to modernize and automate this stuff and we’re definitely going to be open to suggestions, ideas, and most importantly, folks to help test ! :slight_smile:

It’s been ~4 years since I’ve worked w/ cloud technology (mostly AWS), but the company I work for does require that we build our own images. If you have a process to build images, I would be more than happy to test the process for you. I was looking at using Packer (we currently use to build onsite images for VMWare), but looks like to use Packer w/ Azure I need to build something local on Hyper-V, then export it. I’d rather now use Hyper-V if possible.

OK. So the Rocky 8 offer was rolled back with the 9.0 image deprecated.

9.0 will be accessible very soon, and can be seen here in the meantime :slight_smile:

Totally understand this. You can try to use this as a jumping off point for Hyper-V. It uses qemu, but should work just as well with Hyper-V. You will need to post-process the image into a VHD and resize it using the script I linked on the 1 MB boundary. Also make sure UEFI is enabled.

1 Like

Hi the Rocky Linux 8 - official offer on azure is actually the 9.0 image, I just tried it and the release is Rocky Linux release 9.0 (Blue Onyx)
I saw your previous message you said you rolled back to 8 offer, can you double check please as I would like the rocky linux 8 image.
Thank you

Hiya - I am not really sure why, but the image version restored itself… I’ve just republished the change and I can confirm the VM I just launched booted onto 8.6 Apologies for the frustration