Rocky 9 - VMWare error : GLib does not have GSettings support

I tried installing VMWare Player on Rocky 9 using this.

The problem is that I am getting an error the moment I enter:

vmware-modconfig --console --install-all

the output is as follows:

[AppLoader] GLib does not have GSettings support.

I tried looking for solutions but they all seem to apply to other Linux systems and related to problems two years ago.

What could be the solution?

Have you tried running with sudo?

I did everything with su.

Still have difficulties to grasp the difference between su and sudo.

I added myself to wheel and retried with sudo.

Still have the same result.

Thx for your help.

man su writes:

su allows commands to be run with a substitute user and group ID.

When called with no user specified, su defaults to running an interactive shell as root.

If you want to run as account XYZ with ‘su’, then you need to know the password of XYZ.
(That is, typically know pw of root.)

There is also ‘runuser’. See man runuser

man sudo writes:

sudo allows a permitted user to execute a command as the superuser or another user, as specified by the security policy.

There is more control on what your account can run via ‘sudo’ and you authenticate with your own password.

I think I found the issue. It looks like it is related to secure boot which is enabled.

I installed Virtualbox instead, much less trouble :wink:

Thanks for the help and explanations.