Rocky 9 installer: stuck in "Help" screen

This seems absurd, but: How do I get out of the Rock 9 DVD installer “help” screen?

After clicking a “Help” button during the disk selection (to try to determine the minimum disk size for installation), I’m now stuck in the installer’s full-screen help, and can’t return to the installation menu.

There’s no ‘cancel’ or ‘X’ button, or “return to Installation”. The ‘<’ back button is grayed out, hitting ESC doesn’t work, hitting F1 to possibly ‘toggle’ the help menu off, and I’ve tried all combos of Alt-F1, Alt-1, shift-tab, alt-tab, or the common Alt-F4 to close a window. The “hamburger” menu icon at the top right offers no way out either; options are: New Window, Find, Print, Larger, Smaller, All Help. I would expect to see “Quit Help” at the bottom of that menu, and/or a blue “Exit Help” button at least somewhere. The title bar isn’t moveable or right-clickable.

Here’s a screenshot showing the help screen with no visible way out:

Hi @erco,

What happens if you hit either “Previous” or “Next”?

I’ve not run into this, but I haven’t hit help in the installer either.


It just moves forward/backward through the manual pages. The Prev/Next disappear when you reach the beginning/end of the chapter respectively.

Have you tried the ‘ESC’ key, or going to thte end and then see if any new button appears. Of the three boxes at the window top right, what do the other two do?

Overall, this is not helpful.

Yes, I mentioned in the OP that ESC was one of the things I tried.
The other buttons at the top right are just Bookmarks and Search.

Here are some questions you need to ask and answer:

  1. are you installing RL 9.0 as a VM or as a in situ physical install

  2. IF in situ physical install do uou have it installed on a NVMe M.2 drive, and if so is the drive installed on the motherboard (like mine) or via an extender card.

  3. If it is installed on an NVMe card what generation is the NVMe card – mine is 4th Generation – and what brand is it?

  4. …or do you have it installed on an old HDD of spinning rust or a 2.5" SSD.

  5. If you have eliminated all the hardware problems, then this is a software problem. Did Red Hat change the INSTALLER? I pray Dear God they did NOT!!! I KNOW Anaconda, and know how to do a Custom Install with that. If Red Hat changed the installer my curses on them!! If so… I guess I had best dust off one of my 1 TB HDD’s of spinning rust and I had BEST start experimenting with this new installer – I remember the introduction of Anaconda and it took DAYS to get the hang of doing an install with it – Thanks, but No Thanks, I don’t want to have to go through that again.

On the assumption that this is a new installer, does it only come out with RHEL 9.0… or does it come out with RHEL 8.7 ??? [Shudder] !!!

Hmm, @desercat: this thread is about not being able to exit the installer’s Help screen (“Rocky 9 installer: stuck in “Help” screen”).

Is your reply, which is regarding problems about specific hard drive types, perhaps meant for a different thread…?

Exiting the Installer’s Help Screen is not a big deal. It is one that however needs to be dealt with, as it “could be” a problem that extends well beyond this one user. If this is about the Installer Help Screen getting “stuck” then this is an INSTALLER ISSUE. To Exit the Installer – ANY INSTALLER – simply do 1) The " 3 Finger Salute" 2) Reboot from the case (ie there is the “On” and the “Reboot” switch 3) Do a “Hard Reboot” ie unplug the machine – I can’t tell you how many times I have done that or because of a Power Outage. Either way the *Best Answer" is to simply Reboot the Machine.


@erco I’ve edited the post to remove all the unnecessary stuff. You can also flag posts by clicking the three ... under a post and then flag it for moderation when it is off-topic, or for example when a spam message is posted. That way it helps us keep on top of everything, the more eyes that see something, the better :slight_smile:

@desercat Please keep on-topic if you are going to post in a thread. A lot of your first post here had completely nothing to do with the OP’s problem, and therefore has been removed. Please open new posts rather than go off-topic in someone elses thread. Thanks :slight_smile:

I disagree. Yes, aborting and restarting installation does “exit help”, but it is only a crude workaround.

When you are in the installer and have chosen to read help, you obviously are unsure of some choices in the installer and want to continue installation with the added knowledge. You don’t want to start from scratch.

Hence we have questions:

  • Is there a method in the installer to return from the help? If yes, then what?
    If not, then installer UX has an issue
  • If there is no “exit”, is it due to the data that Rocky gives to the installer? If yes, then that is something that Rocky’s team could work on
  • If not, then the issue is in the installer’s implementation and that is something that Red Hat must fix. Basically, one should verify that “no exit from help” exists in RHEL 9’s and/or CentOS Stream 9’s installers too and report that as bug to Red Hat

@desercat addressing your questions:

  1. This is an install of Rocky-9.0-20220808.0-x86_64-dvd.iso on physical hardware (Mac Mini).
    It seems easy to replicate just by booting the installer and pushing Help on the first screen one sees.
  2. The iso was burned to a DVD, and the DVD was used to boot using an external USB drive.
  3. Not nvme.
  4. Not spinning rust, but spinning polycarbonate (DVD).
  5. Unless it’s just me, this seems to be a software/UI issue;
    the lack of a choice in the hamburger menu and the lack of an obvious onscreen widgets to exit all seem to be omissions.

Rebooting is not a workaround, it’s basically the nuclear option because you loose all your custom partitioning info and OS install choices.

1 Like

@jlehtone Thanks for the moderation.

Regarding if this is a bug and who to report it to, I suppose I can pull Centos 9’s install image and see if the installer has similar issues and follow up.

The bug exists in the RHEL9 ISO. I’ve just booted both, and clicked the Help screen. So whilst we could probably fix it by opening a bug on the Rocky Linux bug tracker: probably the best bet would be to open a bug for it on the Red Hat Bugzilla as that way once they fix it, it will trickle downstream to Rocky as well.

I have been unable to find any way to minimise, switch between screens with ALT-TAB or ALT-F4 to close the help window. Really strange.

@iwalker Glad you could replicate, as I didn’t have luck testing the Centos 9 installer; the iso is apparently too large to burn to a DL DVD (at least according to MacOS’s ‘drutil burn’), and when I dd’ed it to a 32G USB stick, it booted into a black screen. :confused:

OK, I’ll see if I can report the problem; I still have a redhat/bugzilla account from the old days (pre-IBM) that I can probably use.

Meh, I seem to be having no luck today with anything:

Will try again tomorrow…

OK, sorry for missing the ‘ESC’ key in the OP.
The way this help screen works is really unhelpful.
I’m guessing this is a new issue in RHEL9, works OK in version 8?


Rebooting is not a workaround, it’s basically the nuclear option because you loose all your custom partitioning info and OS install choices.


:laughing: :rofl: Love your answer. Yep, you loose all your “Custom Partitioning”, but ask me how many times I have had to do re-do “Custom Partitioning” over, and over, and over… Again. I can’t count how many times. While it is very, very ANNOYING :crazy_face: :rage: All in all it takes about 30 - 45 minutes including a complete wipe of my NVMe drive using GParted followed by a complete re-install which includes a complete Custom Partitioning scheme … followed by the actual install – that assumes there is no catastrophic disaster during the install phase… if there is it is back to square 1. At this phase you have 1) just wiped the drive (assuming you do that) 2) gone partway through the install phase 3) and have gotten up to where you have done your “Custom Partitioning” scheme – MAYBE 15-20 minutes at most. Not a great waste of time. Far better than to be almost through with the install – or WORST to actually FINISH the install, only to discover that some catastrophic disaster, after you have spent HOURS configuring the new install and stomping out bugs, only to have to decide if you throw in the towel or not.
We have ALL BEEN THERE, and NO it is NOT FUN, but consider yourself LUCKY – very little invested time is lost.

The OTHER GOOD NEWS is that by asking the obvious questions (to me any rate) we now know this is NOT a hardware problem (though it might well have been) but rather a SOFTWARE PROBLEM!!

The QUESTION you NOW have to ask yourself is: 1) Is there a FIX to the problem 2) Is it WORTH YOUR TIME with all the associated Hair Pulling to work with something that Is Not Ready For Prime Time. Some people get a kick out of doing things like this; Me?!? I won’t TOUCH ANY software marked xyz.0 … for EXACTLY the reason you have discovered – things don’t work, and there are WAY too many BUGS in an xyz.0 release. Seriously, I won’t TOUCH anything before xyz .2 comes out at the earliest or xyz.3 usually. RL 9.0 may be exception, and the ONLY reason I might do that is to get a quick look at the installer and if it varies that greatly from Anaconda. I may choose to stick with the Rocky Linux 8.x series for as long as I can go before I switch over to Rocky Linux 9.x – or maybe simply scrap it altogether in favor of openSUSE – but *THAT * is a REAL CAN OF WORMS, but when it is configured, it runs without too many hiccups.

Hang in there my friend – it is far EASIER to PULL THE PLUG – which I suspect you are going to be forced to do anyway – and wait until Red Hat or Whoever FIXES the BUGGY PROBLEM you discovered.

Best Fishes,
D’ Cat

@desercat Well yes I long since rebooted and moved on past the help issue, and run into other problems (errors creating EFI partitions), but from a UX point of view, this certainly appears to be a bug. So I’ve been trying to revive my redhat account so I can report the bug, but keep getting the internal server error (see above) for the last two days trying to reenable my old account. Had to open a support ticket, lol, just so I can report a bug.

It’s turned into a steep hill just to report the problem.

This seems to not be a problem in Fedora 36; the difference being when you hit “Help” you get a floating window which has an ‘X’ at the top right, so it can be closed. In Rocky 9, the installer help is a full screen borderless window which has no ‘X’. So the simple solution would likely be to just have all the Help buttons open a floating window instead of full screen borderless, and all would be well again.

OK, after downloading RHEL 9 DVD and re-confirming the issue, reported it as bug #2132491 with
2132491 – can't exit installer's "Help" screen (reboot only way out?)

I reconfirmed mainly to ensure if support comes back with questions, I can try what they suggest using an actual RHEL 9 installer. But from what I can tell, it’s exactly the same as Rocky 9’s.

I’ll leave this thread open since there’s no apparent solution, and will try to remember to follow up with whatever RHEL support comes up with.

1 Like