Rocky 9.3 "Problem Loading X.509 certificate" error won't boot to GUI

I was running Rocky 9.2 and suffered a power failure while GPUs (NVIDIA A5000 x 3) were running. Upon startup received the above error but would boot to login gui with older kernel. Stupidly updated to 9.3 and 9.4 and have since lost the ability to boot to gui altogether.

Thought the error was related to this: https://exxactcorporation.zendesk.com/hc/en-us/articles/23142229035287-Rocky-Linux-9-3-X-509-certificate-error But it did not fix it. Turned off VDA switch did nothing. Hooking up a VGA monitor to the VGA port resulted in the same error. Feel this is something with the kernels that was lost with Rocky 9.2.

Asus suggested to reinstall Rocky but hoping for a second opinion.

I am a novice linux user so the solution may be simple but it escapes my abilities at the moment. I can use grub to get to command line and login but cannot run the OS.

Thanks for any help.

But you can still boot in text mode? So you can run journalctl and check exactly what errors you are getting…

Yes. NVIDIA-SMI says “NVIDIA-SMI has failed because it couldn’t communicate with the driver” and the output of journalctl is 3000 lines but has several red entries (these include a Bluetooth: hci0 download error and Integrity: problem loading X.509 certificate . Sorry I can’t paste but here is a pic of the latter.

Since the folder with NVIDIA drivers did not have a .run file I downloaded one of the newest drivers and installed it then rebooted. Upon reboot I get the same error but it progresses to login gui normally now. The crash must have deleted the drivers and caused this issue. The newest kernel for Rocky 9.4 worked but I haven’t tried the 9.3 kernels. Thanks.