Rocky 9.2 - Ansible from epel failing


Ansible used to install correctly using epel but not anymore.

[root@localhost ~]# dnf upgrade
Last metadata expiration check: 0:00:42 ago on Mon 20 Nov 2023 12:30:05 PM.
Dependencies resolved.
Nothing to do.
[root@localhost ~]# cat /etc/redhat-release
Rocky Linux release 9.2 (Blue Onyx)

[root@localhost ~]# dnf install epel-release
Last metadata expiration check: 0:01:01 ago on Mon 20 Nov 2023 12:30:05 PM.
Package epel-release-9-7.el9.noarch is already installed.
Dependencies resolved.
Nothing to do.

[root@localhost ~]# dnf install ansible
Last metadata expiration check: 0:01:09 ago on Mon 20 Nov 2023 12:30:05 PM.
 Problem: conflicting requests
  - nothing provides python3.9dist(ansible-core) >= 2.14.7 needed by ansible-1:7.7.0-1.el9.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

I have ansible-7.2.0-1.el9.noarch isntalled on other 9.2 workstation, but now it seems ansible 7.7.0 need an unavailable python package ?

What does the EPEL package ‘ansible’ have? Collections, i.e. optional roles?
AFAIK, the program itself is in Rocky, in package ansible-core.

(Some) EPEL packages are already built for ‘el9_3’. (Your) Rocky is still a ‘el9_2’.

Rocky 9.3 is GA: Rocky Linux 9.3 Available Now | Rocky Linux
Should show up in mirrors. I’d see what one gets with:

dnf --enablerepo=* clean all
dnf remove ansible
dnf up
dnf install ansible


I did exactly that this morning, but it did not work !
I guess 9.3 was released in the meantime ?!?!

Anyhow, IT WORKS !


1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.