Pre-Login screen resolutions - LUKS passphrase screen

Hi all,

I can’t seem to find any information on the web that suitably solves an issue I’m having on a laptop.
It’s a 13.3inch Dell machine with a “native” resolution of 1920x1080.
The problem: That combinaiton yields very tiny characters in pre-login text modes such as grub2 screen and when entering the LUKS (disk encryption) passphrase.

I successfully managed to tweak the grub2 (“boot menu”) screen to appear in 800x600 which makes for legible character size. All fine on that part.

What bothers me however is that whatever I try to do in grub.cfg (gfxmode, “keep”, …) doesn’t seem to have any effect on the screen resolution used by the LUKS passphrase screen. As far as I understand, yeah, the passphrase screen is originating from Plymouth but I don’t find any documentation that tells me how to configure Plymouth in a way that the LUKS passphrase screen appears in a specific resolution.

All I found on the web is related to Ubuntu, dates back from the grub (pre-2) times, or is a decade old. I tried also to check on CentOS-, RHEL9-, or AlmaLinux- related info but to no avail. Seriously, there must be a way to do that, innit?

Anyone has a hint on how to?
Am on Rocky 9.1 with Wayland.

Cheers, Thomas

What desktop and window manager are you using? I don’t use luks but I did have issues with tiny login screen and solved it on Mate/lightdm. Of course I’ll have to hunt down what I did, but will start looking now.
My laptop native resolution is 2560x1440.

So for me all I had to do was edit the “login screen” settings menu to enable HDIPI support.
On my system F37 lightdm calls the slick-greeter to manage the login window. So in /etc/lightdm is the file:
slick-greeter.conf which contains the defaults I saved this to slick-greeter.orig and then overwrote the .conf file containing only my change.


I found the login menu after I made my edits.

Hi and thanks for your support, but my problem is actually happening way before the login screen appears. That is, it happens right between grub and the login screen. On a side-note, I’m using gnome (GDM) and for tweaking its login dialog I’m using a flatpak app called “login manager” which does a great job.

But as said, unfortunately, the LUKS screen is something completely different. Anyways, thanks again, Cheers, Thomas

Have you tried setting a terminal font as a kernel parameter? I have this on my kernel command line:


This made my tty console usable. It also makes the boot log output readable as it scrolls by.
You may have to install the terminus fonts.

Did this ever get solved?

well, yes and no.
It’s not solved to a suitable extent.

What I can do is use “nomodeset” on the commandline of the kernel to be loaded. That prevents the subsequent processes to load the full-fledged graphics driver and stick to the resolution I choose.
However, that resolution is then carved into stone, even for the GNOME desktop where I’ll find myself unable to change it to something better (in terms of resolution and color depth) than what I selected for the pre-login part. So it’s either one or the other: Live with great graphics in Gnome Desktop but a Plymouth resolution that sucks… OR have the perfect pre-login resolution with a desktop that sucks. Looks like Plymouth doesn’t allow to have both.

That is, unless someone comes up with the magic trick of some kernel parameter OR a plymouth config parameter that I wasn’t able to dig off the internet. :wink:

Anyways, I’m complaining on a high level. The LUKS screen with lower resolution than what the LCD gives by default would just be the icing on the cake of an otherwise gorgeous experience.

Cheers, Thomas

Sorry to hear adding the vconsole font parameter to the kernel didn’t help.