Orca sound distortion / Teamviewer?

Im trying to get orca working correctly for a friend of mine that is sight impaired. The problem I have is that orca is very distorted with static. I can hear the voice but there is a lot of static when it speaks.

I tried a different sound device thinking perhaps its a driver issue for his onboard sound chip. I put in a sound blaster card and I had the same issue. So, Its not a driver issue as far as I can tell. This seems to be an issue with Orca on Rocky. I tested normal sound in You tube and its fine. Its just very distorted with static with orca.

One last question here: Anyone have Teamviewer working with Rocky? I think this is a wayland issue as Teamviewer does connect but there is no display of the desktop - just black screen. Tried giving permission thru the icon in the upper right corner of the screen but it did not do anything. Is there a different Rocky release that does not use wayland but uses xorg?



Don’t think I can with this, but you please clarify how are is audio wired 3.5mm audio or hdmi for example. I only ask cos a google search returned distortion over hdmi.

Looks like teamviewer is currently experimental on wayland: TeamViewer Support on Wayland - Experimental State — TeamViewer Support

If you are using gnome desktop and gdm, when prompted for password on login; in the bottom right corner their is a cog, you can select xorg here. I don’t use rocky with gui, but I think they’re may be additional steps to make xorg default. I suggest testing teamviewer under xorg and if it works, I can dig out the info for making xorg permanent; if required.

Thanks Tom.

1 Like


So, I see what is happening now. The computer has a HDMI/Sound in the video card. Its like a nvidia 1050 and using an HDMI cable but the sound is wired thru the pcie soundblaster card 3.5mm jack with two speakers setup. I went into sound settings and clicked back and fourth between the HDMI sound and the Sound card and it cleared it up instantly. So, I probably have to configure the system to ignore the nvidia hdmi sound. I will read up on that.

Another big thank you about being able to switch to xorg at the login. That did the trick with teamviewer.

1 Like

Turning off Wayland and defaulting to xorg:

Edit /etc/gdm/custom.conf

Uncomment the line:


That takes care of that. Now to disable the HDMI support. I see that even though I turned off the HDMI sound device in sound properties, Orca still gets confused by it. Switching back and fourth a few times between the pcie soundblaster card and the hdmi seems to clear it up.

Still working on the sound issue. Trying to blacklist the realtek snd in the video card.


This may work:

Solution is the last comment. But basically you need to list the sound devices:

pactl list short sinks

Then edit /etc/pulse/default.pa

Add to the bottom:

suspend-sink alsa_output.*hdmi.device* true
set-default-sink alsa_output.*soundblaster.device*

Then reboot.

Thanks Tom.

Thanks Tom,

Seems to be working now. I dont know for sure as I have not tested it enough. This is what I did - not sure if it makes sense though.

I put the original video card back in and removed my test SB sound card and re-activated the onboard sound on the MB. Then booted up and uninstalled orca and dependencies. Then rebooted and reinstalled orca. One last reboot then. Now it seems to be working correctly. I do not have a lot of faith in it yet though.

Really good quote you have there on working with pulseaudio. I will book mark that and study it.

Thanks again, I really appreciate the feedback and help.

1 Like

Well, That didnt last long. Back to the distortion again. I have the 3.5 line out to two speakers. The HDMI video output to a monitor. I tried the DVI port and same issue. I also have tried a SB pcie sound card and an AMD older video card. Same results. So, Im thinking this is an orca problem.

I guess it stands to reason as Rocky is mostly server oriented. Its strength is not in multimedia applications including sound.

I fired up a Mint 20 on the same computer with the original hardware (onboard sound, NVIDIA video card) and experienced the same issue. However, It would correct itself after running for a while which the RL install would not. On boot up it would be distorted and then after running a while it would eventually clear up and run right.

The motherboard is a ASUS Prime x399a motherboard with a 64 core Ryzen threadripper :slight_smile:
The onboard sound is “Realtek ® S1220A 8-channel high definition audio CODEC featuring
Crystal Sound 3”. However, Problem seems to be with other sound chips also.

I guess this will be one of those problems you think about when your falling asleep at night. lol…
Thank you all for the input on this.


Have you tried disabling hdmi audio with pactl? info in my last post.

Thanks Tom.

Hi Tom, I have not. Im sorry. I will try that tonight and see what happens. Ill post back by morning at what I find out.

Dont you hate it when you suggest a possible cure and the OP doesnt do it? lol… I promise, Tonight I will do it. In fact, Ill kick up the computer and try it in a few minutes. :slight_smile:

1 Like

@tjdoyle I tried your suggestion and Orca then had no sound. Unfortunately, I got side tracked after that with a raid drive replacement for a client. I am going to put this on hold for now to fix a bad raid setup before the holiday hits. I will also probably ask about this in the orca mailing list.

Thank you for the replies and hope you have a great weekend. If your in the States - Happy Memorial Day. :slight_smile:

1 Like


When you get back this please could provide the output of:

pactl list short sinks


tail /etc/pulse/default.pa

Thanks Tom.

Tom, I appreciate all your help. My client called and they are moving to Alabama so I no longer have access to the computer. So, I guess we have to end it right there. I did get it to the point where it would be bad sound for the first minute or less and then clear up.

Sorry I am so late in posting back. :slight_smile:

1 Like