Nullmailer or a simple MTA like Nullmailer


I have used nullmailer ( nullmailer) on ubuntu systems for simple forwarding mails.
Unfortunately it is not available on centos/rocky and i cant get things to work.

tried to create an rpm out of debian deb
tried to follow the INSTALL documentation from (
Both did not work in the end
Sadly i don’t know much about this compile/install workflow

Maybe someone of you know a way to get it working or can suggest a different MTA
Maybe there is something like nullmailer in the centos world?

I don’t need to receive mails
I only need to forward local sent mails

Thank you for reading!


I use the msmtp package from EPEL repository. Simple to configure and works very well.

I can build nullmailer on my RockyLinux 8.6. The c++ compiler (package gcc-c++) is required:

cd nullmailer-2.2
1 Like


I also use the msmtp package from EPEL on my Rocky Linux 8 server instances.

Zero problems encoutered with that simple MTA as I’ve already been using it for years on my previous CentOS 7 servers before.

However, I’m now trying to install msmtp on a Rocky Linux 9 test server, with the EPEL Repository activated, but I cannot find that package in EPEL anymore.

Does anyone know if it’s going to be available in EPEL soon, or should I start searching for another lightweight MTA to send my mail through a SMTP server ?
I prefer not to install Postfix or the like 'cause these seem like overkill for my use case.

Thanks !

I don’t know if it will be in epel or not, the epel guys would know more on that. However there is esmtp which seems to be similar to msmtp. That package was available in epel under Rocky 8 as well. It’s available in epel under Rocky 9 so could be a lightweight alternative to use if epel don’t provide msmtp in their epel9 repo.

I built msmtp from a Fedora 34 rpm. I don’t think there were any problematic dependencies, that is, when I did dnf -y builddep msmtp.spec it completed without errors. There are rpms for the even simpler ssmtp. That used to be easy to configure, and when I was just using one account, I used it. I haven’t used esmtp, just because msmtp was so simple to build. Anyway, if you want to build msmtp I have a quick summary of building from srpms at Building rpms. Do pay attention to the warning to not build as root. In the case of msmtp just grab the srpm from, they give a link to a page that has a link to the fc34.srpm.

1 Like

found this topic because I was looking for msmtpbecause esmpt and ssmtp are no longer maintained. I also ended up building an rpm myself in a podman container. I really don’t know why it isn’t (yet?) included in the standard repos. It was available in RHEL7 and RHEL 8.

I used this spec file: Tree - rpms/msmtp -
(left out the patch and updated msmtp to the latest)

piece of cake.

Thanks @iwalker for the esmtp suggestion, however, the package doesn’t seem to be maintained anymore (as mentionned on the project’s page).

Meanwhile, I filed a request for msmtp to be packaged for EPEL9.

1 Like

I filed a request some time ago on bugzilla.
It seems that the msmtp software has been packaged and is in testing as of today.
It should therefore be landing soon in EPEL9.

1 Like