No dual-boot option whatsoever

I sliced off a partition from my laptop SSD ~75gb worth to dualboot Rocky Linux with Win11. In the past, Ive never had troubles dualbooting win10 with ubuntu or manjaro. I went through the install process of rocky and I completed it and rebooted, but when I rebooted I was at my Windows login screen - I was never given an option to choose what to boot. I checked in advanced settings, Rocky is not listed in OS list. I checked all around google and other places, no tutorials worked, no grub2 install guide helped, but from troubleshoot menu I can clearly see with ls that I have all the directories and stuff there.

What now? Is it over for me?

I have no experience with Win11 but do know that you have to disable “Fast Boot” in the board firmware. This may be just the first step.
When you say “trouble shoot menu” are you referring to the Rocky rescue mode or the firmware utility?
When you installed Rocky did you have it create it’s own EFI partition?

1 Like
  1. It’s already turned off.
  2. Yes. I entered troubleshoot from the boot USB and I tried rocky rescue mode with the “press 1 to mount to /mnt/sysboot” and those chroot commands people suggested on the internet
  3. Honestly IDK. All the partitioning was automatic. Im gonna attempt installing again. Also of note is that I needed to use an online repo link in the install source for some reason. In the installer I can see “/boot/efi EFI System partition” and “/boot xfs” and “rl Physical Volume (LVM)”, so I think it did install an EFI partition.

I tried this too and all the commands worked but still no boot menu and i still automatically end up at win11 login screen

So…I reinstalled rocky again and it worked and now I am dualbooting… what changed this time? Idk, i just did manual partitioning and that’s it… somehow now everything is good. Was it really the manual partitioning and adding both a /boot/efi and a /boot mount? idk

leaving topic open for post-resuscitation analysis

It seems my solution of adding both a boot and boot EFI mount was the solution, as Rocky decided to use the regular boot mount for some illogical reason

I had a similar issue a while back. I did a quick fix I just resized my Windows partition and put RL on the new clean partition. I set Linux to boot option 1, to run Windows I go to BIOS and chose it there.