Need some help migrating from Centos 7 to RL 8.5


If anyone can help, it would be greatly appreciated…


  1. Using Centos 7, I didn’t specify any ssh agent, so I assume it was preinstalled in the image I installed in vmware workstation and any terminal session I start (new window or new tab) once my keys were added, all terminals had access to the keys via the agent, now, that doesn’t work, in fact, it seems to be specific to each terminal window and directory I added the keys and I have to run this each time to add keys: eval $(ssh-agent) and also, I could run this script ( in bash from any directory before:
    ssh-add my_key
    ssh-add my_key2

    and my keys were added and I was all set to use them from any terminal, now that doesn’t work plus I have to add the full path to the keys, e.g. ssh-add ~/.ssh/my_key

Session Management
2. In Centos 7, except for Netbeans, applications like kwrite,kate,terminal windows on restart would re-open where I left off, now they don’t. Is there a way to bring back sessions on reboot?

3. Selinux (setroubleshootd) when running redis-server starts to consume constant 18% cpu utilization, had to disable it, are there any issues disabling it?


Gnome has it’s “Passwords and Keys” (seahorse from the command line) and it can handle ssh keys. However, you need the private and the public key in place. Open seahorse, click ‘+’, select “Secure Shell Key”. Keys added to seahorse are unlocked by logging in to Gnome.

Thanks, I’ve installed KDE on RL8.5, so I’ll try using the kwallet like I do in Centos7.

This is going to take some effort and have do a lot of digging. I relied too much on Centos7 / KDE to do stuff out of the box without me knowing much on how everything worked, just that it worked. Thanks again for your help. Looks like session management not available or broken and as for selinux, at 18% pretty much constant, CPU utilization driving up the watts consumed by 6w, it cost $1.07 a month at 25 a Kwh for something I have no clue what it’s doing let alone it knowing what it’s doing.

Regarding keys / sessions across multiple tabs/windows, adding this worked for me:

[From Sharing the same `ssh-agent` among multiple login sessions - Super User ] I didn’t do this in Centos 7, so I’m not sure how its working there.

Add this to your .bashrc file

function start_agent() {
killall ssh-agent 2> /dev/null
ssh-agent | sed ‘s/ Agent pid//’ > $SSH_ENV
ssh-add -t 25920000 ~/.ssh/my_key1 2> /dev/null
ssh-add -t 25920000 ~/.ssh/my_key2 2> /dev/null
ssh-add -t 25920000 ~/.ssh/my_key3 2> /dev/null

mkdir -p “$HOME/.ssh/agent”

if [[ -e $SSH_PID_FILE ]]; then
PROCESS=$(ps -p $SSH_PID -o comm=)

if [[ $PROCESS == 'ssh-agent' ]]; then


Regarding KDE Plasma Wayland, after a recent OS update to RL 8.5, now when I restart, my browser session is restored, but not kwrite, dolphin and console sessions. I made the settings to allow for it in system settings, but it’s partially working / partially broken, not what I expect to have happen.

As for selinux, complaining about running a perl script that is used from vmware, so I just disabled it using:

  • Open the SELinux configuration file: /etc/selinux/config.
  • Locate the following line:
    Change the value to disabled :
  • Save your changes and close the file.
  • On the next reboot, SELinux is permanently disabled. To dynamically disable it before the reboot, run the following command:

setenforce 0